How to hide zero values?

I don’t want zero values displayed

Tools - Options - LibreOffice Calc - View; under Display uncheck Zero values; see if this works for you. Note that this is a global setting; it will apply to all spreadsheets.

If this answer helped you, please accept it by clicking the check mark :heavy_check_mark: to the left and, karma permitting, upvote it. That will help other people with the same question.

Thanks for the tip, I knew that method worked tho, I was needing to hide them the other way thru formating on just this one worksheet. Sorry if I wasn’t clear about that. It worked very similar in Excel, should be easy enough to figure out but somethings just not exactly right and its not hiding the zeros using the semicolon. I tried the excel formula also and it didnt work. what else could be causing that not to work?

If you only wish to hide zero values in specific cases then set a custom number format that ends with a semicolon. You can start by setting one of the standard number formats and then append a semicolon to the end of the definition of that format.


  1. Select one or more cells.
  2. Right click the selection and choose
    Format Cells.
  3. In the input field labeled Format code, append a semicolon;”.

The answer from @robleyd is also accurate but removes zero values globally, as in all spreadsheets. There are times when it is desirable to display zero values, which is why I provide this answer.

I can’t upvote yet but this is brilliant! I wanted blank date cells so needed two semicolons. From Number Format Codes - LibreOffice Help In a number format code with three sections, the first section applies to positive values, the second section to negative values, and the third section to the value zero.

I attempted this format without any luck, it still showed the zeros. my format was to be 0.000, 3 decimal places. I used 0.000; as the format code and it would not allow me to click the green check box to save it. I have a screen shot of it but unsure how to post it

As @paulzag mentioned, the syntax is positive semicolon negative semicolon zero. in your case you have to use 0.000;0.000; (same format for positive and negative, no format on zero). @lazarus477 probably had a custom negative formatting by e.g. checking the “negative in red”-checkbox

Some of my zeros show as blank and occasionally they do appear. I want them to appear, but the method described doesn’t work for me. However a work around is to add a tiny amount to the value say £0.000001 and then it displays as £0.00.