How to insert/import a Draw file containing a single symbol, without the empty space, into Draw?

So far saving symbols as Draw files with 1 symbol per file seems the best way since saving as picture will screw the symbol up, but inserting one will regard all the empty space, which is extremely bad.

For the future:

What kind of symbols?

Have a look at the Gallery. It is designed to be a collection of single shapes. Generate your own Gallery-Theme and drag the shapes into it. The Gallery can take a lot of formats. Using the Gallery you can pool related shapes

When you want to use an .odg document to store the shapes, then you need to name each shape. When you will later on insert a shape into a new document, use menu Insert > File. You get a tree representation of the content, where all named shapes are listed and you can select a single shape from there. By using a document you can pool related shapes.

When you will export a single shape, you get a small file size, if you use one of the vector formats. Select the shape and don’t forget to check “Selection” in the export dialog, otherwise you will export a whole page.

Well, electric{ity|al} circuit in this case, but applies to every kind of such symbol.

Then you should look at Electrical and Fluid Schematic Palettes/Templates - #6 by luyu or directly at

Hm, apparently LO has issues with some characters in shape names, such as slash, “/”. I did name the group but with a slash the tree wasn’t shown in the first place. Gotta report that as bug …

That gallery arsenal looks good, but it’s in German. I tried, with my limited friendship with Google, to look for free symbols of TIFF, PNG, SVG or PDF, before posting this question but found none [not counting Google image search, which gives pieces that aren’t symmetric], instead alot more unrelated stuff, so I’d appreciate more links, please. If it’s native OpenDocument/LO, all the better. I have my ways.

Bug report:

Chosen as answer. It seems LO 4.4.0 will have this problem fixed.

Final comment: using 4.3.0 RC2 it works perfectly. Also tried the portable version of and worked fine with the example file, so maybe some line of code sometimes causes the window to not appear. We’ll see it later, I think.