How to move LibreOffice customizations from Xubuntu 18.04 to Xubuntu 22.04

I just installed Xubuntu 22.04 with LibreOffice moving from Xubuntu 18.04 (latest LibreOffice for that system). I still have 18.04 on my computer in a separate partition, but it doesn’t run. I would like to move all my customizations from 18.04 to 22.04. These include toolbar customizations, templates, macros, and maybe some other settings I don’t remember. How can I do this???

Have you made a backup of your user profile before?

Backing up the user profile at regular intervals

If there is a separate home directory for 18.04:

  • open this directory

  • go to .config/libreoffice/4

  • copy folder 4 to your new home directory, .config/libreoffice/

All you have changed in LibreOffice will be saved in this folder, if you didn’t save, for example, macros separately or macros in files you created. Tools → Options → LibreOffice → Paths will show the same folder.

Thank you for responding. Both the response from Hrbrgr and you were very helpful. I copied the folder as you suggested and everything worked, except for one item. In my old 18.04 system I had a templates folder in /home/ralph. Now every time I start writer from the whiskers (start) menu, I get an error message that writer can’t find a particular template in /home/ralph/Templates. Of course, it is never going to find it, because it is on another disk partition. But I don’t know why writer wants it, because I am not opening an existing document. I went to Paths and I have no path to /home/ralph/Templates. What could be causing the strange behavior and how might I fix it???

Thank you for responding!! Your reference to Preventing data disaster - The Document Foundation Wiki was very helpful and I learned a lot about how libreoffice is configured helping me solve my problem. However, I still have one problem. See my response to @RobertG. Any help is appreciated…

What is the content for Tools → Options → LibreOffice → Paths → Templates? Should be in your home directory an then .config/libreoffice/4/user/template.
Open this directory with a file manager. Is there any link inside this folder, which tries to connect to /home/ralph/Templates?
Does the error appear with old Writer documents or does it appear for every new Writer document?

1 Like

Have a look at the post by @ajlittoz :

Guys, thanks again for responding so promptly. I really appreciate it, especially when I seem to be facing so many issues, when installing a new OS. I solved the problem. Under 18.04 I had my default template stored in /home/ralph/Templates. Apparently this file location is stored someplace, I don’t know where, but got picked up by libreoffice in 22.04. All I had to do was bring up writer, go to File>Templates>Manage Templates>Manage>Reset Default Text Document, and writer no longer wanted a template in /home/ralph/Templates. Now it is on to my Firefox scrollbar problems.
Thanks again for your help.

1 Like