How to resolve Copy/paste problem?

Hello. It seems that there is a bug in both last Still and Fresh version.

It is simple as that: sometimes when I try to paste something into Writer document it put the previous material from the clipboard, not the last one. So I need to save the document, close it, reopen it, put “Paste” and only in this case it will paste the correct last piece of the clipboard.

Annoying thing.

Has anyone encountered with the same problem? How to fix it?

To developers: please investigate into this and if it is a real bug than

Roman

What version of LibreOffice/operating system are you using?

I have tried both versions Fresh (LibreOffice_5.2.0_Win_x64) and Still (LibreOffice_5.1.5_Win_x64).
I am using WIndows 10 64bit

I note that this bug has already been reported Bug 101257. But the status was needmoreinfo. I added some more information just now and changed it too “Unconfirmed”

There have been numerous bugs reported concerning copy/paste in Windows. See answer, response, and bug report on this post (click here) where MS Edge was part of the problem. Personally no problems using Linux.

Thank you for response. Had a look at the link provided but as far as I remember in my case MS Edge still was not opened when it was not possible to paste new material into Writer, but I am not 100% sure. I tried to copy form Notepad, MS Edge, Google Chrome. In all the same cases it was not possible to paste it into Writer document, it put the previous material but as I already mentioned I am not 100% sure if MS Edge was closed. Normally I use Google Chrome

@romanokun In future please respond with comment. In the link, the problem was Edge. When it was closed, the copy/paste worked properly. One of the bug reports mentioned "other software may cause some of these problems ". Windows affects the clipboard in various ways now and the only way to fix some of the problems associated with LO is to report as a bug what specifically caused the problem. Not really a LO bug but a change in Windows requiring a change in LO.

Anyway the problem should not be present even if MS Edge is opened, But for temp solution it might be OK. If it is really Ms Edge than it is some kind of relief to know what exactly causes a problem. Next time I will pay attention to if the MS Edge is opened if the same problem repeats. Thank you for response

Keep in mind in your case the problem may be when Chrome is open or possibly something else.

If the problem is just that the second item in the clipboard queue is being pasted, instead of the last or top item, then a successful work-around might be to Copy everything twice before Pasting, so that the wanted item occupies both the top and second positions in the clipboard queue. Does that work?

I’m sorry, but I am not familiar with MS Edge.

It is Windows 10 browser. As stated in comments, "other software may cause some of these problems ".

Windows 10. Disable Tools>Options>Libreoffice>Advanced >enable macro Recording