I have been trying to create a new database in base but it keeps telling me I have a problem with Java

What do you mean by “Versions after Oracle Java 8 are not supported since LibreOffice 6”? Start with clarifying which version is “6”? In LibreOffice, at least two first digits denote a major version; e.g. v.5.4 is a major release; 6.0 is a major release; 6.1 is equally major release. Then up to (including) version 6.2, the minimal supported version of Java was 5; for 6.3, minimal Java was 6. Starting with LibreOffice 6.4, minimal supported is Java 8; and versions after (i.e., newer than) the minimal supported versions are also supported.

It’s all described in the FAQ.

I tried any Oracle jre more than 8 (9, 10, 11 no works) in (x64) and (x86) and it’s not recognized, only the adoptopenjdk works. Specially if you try to run example database provided in this website (older like 2017 and back)

“I tried and it’s not recognized” is not the same as “it’s not supported”. Had you filed a bug report for that?

Sorry, (replaced supported by not recognised) I will do now… I cannot, I deleted all the jre 9, 10 and 11 from my machine

I do not think so. I am using Oracle Java 8 with LibreOffice 6.4.4 and it is working perfectly.

Try using Oracle Java 9, 10 or 11,