I have donloaded LibreOffice but it won't install. I get error 1500 saying I'm installing something else when I'm not.

I’m using windows 10.

The following Registry Key is (on the face of it) responsible for this error:-


However, you need to tackle whatever has caused that key to be activated in the Registry rather than dealing with surface symptoms. Naturally, that could originate from a hundred different places, including places like Windows Update.

Try the following until you get success on install:-

  1. Shutdown all installation attempts, restart your computer, then try again.
  1. Try the “Microsoft Fix-It” website:-

"Automatically repair issues that block program installation or removal because of corrupted registry keys."

This is an attempt by M$ to help you avoid the ultimate fix for MS Windows, which is to wipe the disc & re-install the OS + Programs from scratch. It is a replacement for The Windows Installer Cleanup utility (MSICUU2.exe) which has been retired by M$ as they said that it corrupted some Registry instead of fixing them (whoops).

The website will test out + fix the Registry. There is also a Windows Update onsite (bad M$ configuration of Updates is one of the sources for this error) & it seems more thorough than the normal Update.

  1. Restart.

    If you did not use the Windows Update in the previous step, go back & use it. If necessary, after a restart go back & see if there are any more until it reports that everything is updated.
  2. If, after a restart, you get the same error then you need to wipe your disc clean & reinstall Windows + update & try again.
  3. At this stage it’s a bug, no mistake.
    Use Bugzilla or the Bug Submission Assistant + point out that Windows was installed on to a blank disc then updated immediately prior to LO installation.

If this helps then please tick the answer (:heavy_check_mark:)

…and/or show you like it with an uptick ()

I’m sorry but the above answer is a bad answer…WAY too complicated and overkill - messing with the Registry and ESPECIALLY reinstalling Windows(?!) is ALWAYS A LAST RESORT!

The problem is that there is more than one MSI installation process going on at the same time. So you need to get rid of the processes conflicting with your current MSI install. I had this problem just now installing LO and here’s how I fixed it:

When you get the error:

  1. Don’t close the install - press Ctrl+Alt+Del and open Task Manager.
  2. Click the Name field to organize your processes with Apps first (at the top) followed by Background Processes (and Windows Processes) below.
  3. Below Apps, scroll down until you find processes NOT in Apps called something like msiexec (I had two in addition to the running MSI install app). These were the culprits on my Windows 8 machine. right-click them and select End Task. Make sure you keep the currently-running MSI install App running of course!

Click Retry or (if I remember correctly) the window should automatically disappear and the install should continue without problems. You DON’T need to reinstall Windows or mess with the Registry!!

Strangely, I did exactly the same thing on a 64-bit Win7 computer and did not have this issue.

Hope this helps!

Go to MSConfig.exe. Click on Selective Startup then Load System Services. Reboot and continue to load version. When finished go back to MSConfig and select Normal Startup. That should do it.