Is there a known bug in 5.1.2 re Pivot Table use?

++ Upgraded today 1/5/2016 and selected 5.1.2 which seemed to insatll oK. Checking out various files found odt files seemed OK but one of my spreadsheets (most of which have Macros/ multiple sheets, etc.) would open but gave a “Fatal Error 5.1 Unknown SEH Exception”.
++ This happened whenever I tried to select one of its sheets which contains a Pivot Table. Only one of my other spreadsheet files has this & that one is a collection of all my prior year versions of the problem spreadsheet.
++ I WAS able to open this ‘history’ file & select one of the Pivot Table sheets, which opened with only Column J onwards on display. The fatal error occurred again here when I tried to cursor home!
++ After a lot of messing about (Restored my PC prior to the Upgrade and tried again, same results, etc. etc.) the solution I am presently using appears to be working fine. This was to Uninstall 5.1.2 and then Install which is OK for now but I am worried about future upgrades.

Look at this Post.