Is there a way to set LO to open text files as UTF-8 or to default to txt (Choose Encoding)?

When I open txt files many characters get garbled because they are UTF-8 encoded. I would like to have LO default to using UTF-8 when opening text files (like OpenOffice does) or at least have it pop up the ‘select encoding’ box. There are so many options under ‘file type’ when opening files that I can’t find what I want.

When you say that you open txt files you mean from within LibreOffice or by double clicking them?

Choose the file type 'Text - (Choose encoding) (*.txt)

I am aware of that method. what I am looking for is a way to make that the default like OpenOffice does instead of having to go through the filetype pulldown. Since almost ALL of the text files I am working with are UTF-8 encoded, it is a pain having to go through the filetype pulldown every time. Having a config setting for how text files are opened would be nice.

Then maybe you can find a solution in this thread Change text encoding for reading from text file (Macro)

Creating a “shortcut” with hardcoded filter, and using it for those files, could be an option. E.g., on Windows, you may create a shortcut on desktop having command line like

"C:\Program Files\LibreOffice\program\soffice.exe" --infilter="Text (encoded)"

and drag TXT files onto it to have the “ASCII Filter Options” dialog shown. You may also add filter options to the command above to fix to using UTF-8 - see --infilterin the relevant help.