Just installed version from older version 3.4? JRE missing

I was using an old version (3.4??) of libre office and just installed version When I try to use base to access my embedded database I get the message "The connection to the data source ‘xxxx’ could not be established. No java installation can be found. Please check your installation.

I am running Windows 10. The box is ticked for ‘use a java Runtime Environment’ but there are no Java versions listed. I am not sure why no versions appear as I was using a very old java version and it had appeared along with many other versions. I’m not sure why all the versions I have do not appear. From investigating other topics I believe I need to install a more current version but am not sure what version, whether it is supposed to be JRE or JDK, where to download from, how to add it to Libre Office?


Your old version of LO was 32-bit. You must have upgraded to 64-bit LO and therefore you need to install 64-bit JRE. LO & Java must match bit-wise. See this post - on firefox and have loaded java 32

I am not sure which Java SE to download 1) Windows X86 Offline 2) Windows X86 3) Windows X64 Offline 4) Windows X64. I would think it would be the X64 one but wish to confirm and whether it should be offline version.

x86 is 32-bit & x64 is 64-bit. Here is current version which link should have gotten you to: Java SE 9.0.4

You should be able to use the .exe version.

Thank you for your help. I downloaded the Java SE 64 bit but it says it cannot run on my PC. I think I should have downloaded the Libre Office X86 version instead of the X86_64. Can I just install the X86 version or do I need to do an uninstall of the X86_64 version first? If I need to do the uninstall how do I do this?

@bpq9999 Is your Windows 10 a 32-bit version? If so, that is the problem & my fault for not asking. Otherwise the 64-bit version should work. Also, since we’re at it, what LO did you install - 32 or 64-bit?

It says I have a 64 bit operating system, x64-based processor, Windows 10 Home Version 1709. Libra Office Version is (x64).

There is no reason I can see where the Java pointed to in my comment (and also in link in answer) would not work. Is the install working? What error are you actually getting & when - during install, etc.? You cannot use x86 version because it simply won’t work with the LO version you have installed. What exactly is the Java download you have tried (the download name please)?

I clicked on your link above and selected jre-9.0.4_windows-x64_bin.exe and saved to This PC → Download folder. Two files appeared in this folder, one with the above name and 0 size which, when I clicked on originally I got the message. The other file ended it part but while I was typing this it changed to 1 exe file which I clicked on and this time the install seems to have worked. I guess I clicked too fast last time I downloaded.

So the question after all that, is Base now working on your system?

After installing Java I went back into base → Tools → Options → Advanced and it let me add this Java Version. So far the database looks good. Thank you so much for your help. Am I supposed to do something to close this?

If this answers your question please tick the :heavy_check_mark: (upper left area of answer). It helps others to know there was an accepted answer.

No real need to actually close. If wanted this is in lower right of your question.