Libre office writer is really slow

I VE just upgraded to debian 10 libreoffice 6.?. With gnome its very slow. I have to wait for a minute b4 the doc start responding. However, if I change the desktop to xfce, lbreoffice is very fast. Any hint to improve?

I have same problem old 5.n version was 10 times faster and new UI sucks. wish I could revert to old UI. new font color picker also sucks. you. have to remember the dam Shad of color. Also new photo alignment down menu icons? What the hell to they mean. What the hint tells me is meaningless. All in all IMHO the new UI sucks. WPS product is better

Win 10 Pro, v1809 (build 17763.678)

LO 6.2, 6.3.x

Editing styles was painful – taking 1-2 min. to lad the window – until I changed my default printer (networked, IPP) to a local PDF printer. Now it works like a charm!

That looks like a bug (performance issue) with a good repro scenario - would you please file it?

The printers have NOTHING to do with editing. You must have done something else without knowing.

Just disabling openGL worked for me, now the writer is working quite fast. Thanks manipot.

i can not find openGL option in my libreoffice options

rewrite in Assembler

I’m using Libreoffice 7.1.1 on Xubuntu 20.04 and it was impossible to work with
Writer because it was extremely slow to respond to keystrokes.

Now Libreoffice is incredibly fast because I removed two things:
I closed Libreoffice and uninstalled

It is a pleasure how quickly it works now.
The only ‘downside’ is that the styling of Libreoffice is a bit less modern.

Xubuntu uses Xfce desktop manager, not GNOME nor KDE. This could explain the behaviour: widget libraries for GNOME and KDE are not present.