LibreOffice 24.2.3 can't control font colours in Application Colours

Hello. When I was using Fedora 38 since last summer, whatever Libre Office was in their repo’s allowed me to control the “Document Background” and “Font” colours. I like to set it to a gray page with a black font because it’s much easier on the eyes.

Since I was forced to upgrade to Fedora 40 a week ago because Fedora 38 went out of support, I noticed that my Applications colours were reset. The page turned white with black text (which is normal), so I attempted to change that to what I had before.

I could change the page’s background colour to gray but I had no control over the font. The font colour would be automatically set to something LibreOffice decides, almost as if it was automatic.

When I set the “document background” to gray, the font text turns white.

When I set it to white, the font turns black.

When I set it to yellow (as an experiment), the font turns a bit grayish.

Here’s the menu in question:

LibreOffice Info:
Version: 24.2.3.2 (X86_64)
Build ID: 420(Build:2)
CPU threads: 16; OS: Linux 6.8; UI render: default; VCL: gtk3
Locale: en-GB (en_GB.utf8); UI: en-US
Calc: threaded

Confirmed this also occurs in Windows 10 with version 24.2.4.2

Tried setting background first, then text and LO seems to override text color when it thinks it will be illegible despite it being manually set.

So, this is a bug of some kind?

That totally sucks if true. Won’t it take a long time for a patch to be made?

A bug fix will never happen - unless someone reports the bug.

1 Like

It’s magically working now that I tried to reproduce it for bugzilla.

It seems that certain conditions apply for the bug to “work” that are somehow no longer present in my LibreOffice install. I didn’t do anything so I don’t know what’s different now.

Maybe @Ash733 can file the bugzilla report.

@miihatsu23 any idea what changed? Can you at least give me some hints as to what these conditions might have been? I have a relatively fresh install with minimal changes so it seems to occur ‘out of the box’. Happy to file bug report if you can give me some more info on what fixed it.

Bug report submitted: 161595 – Manually set application colors not respected for some combinations

The font color setting is indeed “buggy” - if you consider that setting sensible at all. Controlling “automatic” font color, which is designed to change automatically, depending on the background … It would need (1) at least two settings (for dark and light backgrounds), and (2) the user understanding what they do.

Currently:

  1. When the manually set automatic font color is dark, it is only respected on light backgrounds (i.e., on dark backgrounds, white font is used for automatic) - which is IMO sane (taking into account the single color setting);
  2. When it’s light, it is used on all backgrounds (even on light).

But the very idea of fine-tuning automatic font is IMO useless. If a user needs a specific page decoration, manual settings of background and (possibly) font colors should be needed. The usecase here (what @miihatsu23 and @Ash733 are trying to achieve) is unclear. Note that document background is screen-only setting…