LibreOffice 6 on Ubuntu Linux, soffice.bin 100% cpu load

Hi all,

I’m running LO on Ubuntu Linux 18.04. As with previous versions, the process soffice.bin frequently shows a persistent 100% CPU load, heating up the CPU and draining my laptop battery.

I usually have several documents open in Writer and Calc at the same time, on of which is rather large (185+ pages with about two dozen images). That might be related to the problem, however if LO is starved for memory I’d expect that to take the form of slowed response, increased swapping and the like, not a maxed out CPU load.

Old (and now apparently obsolete) forum posts suggest tweaking memory settings, which as far as I understand no longer applies. I can’t find any other “tuning” options in LO, unless there’s something under ‘advanced’ that I’m unaware of.

Suggestions, anyone?

// FvW

Same issue here.
The memory settings can be tweaked under ‘advanced options’, but apparently that’s not recommended and probably unrelated to the issue (according to LO).
Some posts said it’s an issue with glib2, and deprecating solved the issue for some people.

Funny thing, I found out that the issue only happens when I open the odt version of my document, but not the docx.

same here but with 16.04.

Same issue with similar usage. Windows platform (Windows 7 x64). Libre Office version (x64). I have also noticed that this happens more often when opening MS Office files.

I’m also finding libreoffice spreadsheets unusable due to this bug. It starts consuming 100% cpu and making certain actions take excruciating long. Last time this happened, it was when I tried to insert a column in a small spreadsheet. Also under Ubuntu 18.04 (mint mate 19.1).

CONFIRM OBSERVATION BY oamoti: I have a large document (114 pages, 33,000 words, 180,000 characters) with perhaps 80 images. When stored as an .odt file it opens slowly, saves very slowly, and consumes 100% of one of my eight cpu’s (htop) when the document is open even if I am doing nothing. Following the observation above by uamoti, I saved it as a .docx file. It now opens very-quickly, saves quickly and no longer consumes much cpu. (UBUNTU 16.04; LO

Opening basically any .odt, no matter the size, is going to produce 100% load on a single CPU thread in Ubuntu 18.04.

Similar problem when crashes, select restart use until next time :frowning:
Observations suggest is too much CPU% - what can we do ?
top - 16:26:20 up 8:57, 2 users, load average: 0.39, 0.34, 0.51
Tasks: 193 total, 4 running, 189 sleeping, 0 stopped, 0 zombie
%Cpu(s): 60.6 us, 3.0 sy, 0.0 ni, 36.4 id, 0.0 wa, 0.0 hi, 0.0 si, 0.0 st
MiB Mem : 14941.78+total, 9529.934 free, 2845.270 used, 2566.582 buff/cache
MiB Swap: 32767.99+total, 32767.99+free, 0.000 used. 11425.96+avail Mem

15209 paulpar+ 20 0 763536 302252 143316 R 106.7 1.975 0:24.37 soffice.bin
2541 paulpar+ 20 0 342624 64828 45368 S 13.33 0.424 1:03.24 gnome-terminal-

Using LibreOffice since it became available, vague memory of similar eons back which recall was resolved fairly quickly.

Even observing CPU% on terminal and pausing when 50+%, it can still manages to crash before notice it rising.

On linux with RAM and Swap memory available, can we reduce or slow down soffice.bin 's usage of CPU% ?

Why is soffice.bin doing this, and can we track what is happening ?


I experience also, that LO needs a kernel of the CPU to 100% - in Windows 10 as under Debian (latest).
This is since a year or more. It seems to be independent to the system. In my case a text of severel hundred pages (an about 700 kB of the odt-file) seems to cause it.

As I see the comments, the problem is experienced since 2011 or earlier.
The problem has been closed systematically by administrators. Why?

Under Windows 10 I use the latest Version of LO. But even there it occures.

SAVE ALL OPEN DOCS, THEN use pkill soffice.bin. Re-open libreoffice and let it recover your open docs.

See my full answer to this on Ask Libreoffice here: why is soffice.bin using 60% CPU with nothing open? - #2 by eRCaGuy
and on ServerFault here: ubuntu 16.04 - Soffice.bin high CPU usage - Server Fault.

How is this an acceptable answer? Kill the 100% CPU process and start again? Really??

Killing any process will take it down to 0% CPU, by definition…

It’s now 2021 and this problem still recurs almost every time I use LibreOffice, whether editing a document or spreadsheet. Large or small document or spreadsheet, it still happens. All I can do is open it, make a few edits and then close ASAP rather than have it chomp up all my CPU in the background.

Build ID: 1:6.0.7-0ubuntu0.18.04.10
CPU threads: 2; OS: Linux 5.4; UI render: default; VCL: gtk3;
Locale: en-GB (en_GB.UTF-8); Calc: group