LibreOffice 7.4 convert docx/txt to pdf error


I’m trying to upgrade to LibreOffice 7.4 from 7.3. I’m using LibreOffice to convert txt/docx files to PDFs using the cli

libreoffice7.4 --headless --convert-to "pdf:writer_pdf_Export" "/home/myuser/converte/docx/test.docx"

This works ok with the older versions (7.3 and lower) but on 7.4 I am getting the below error

javaldx: Could not find a Java Runtime Environment!
Warning: failed to read path from javaldx
convert /home/myuser/converte/docx/test.docx -> /home/myuser/converte/docx/test.pdf using filter : writer_pdf_Export
Error: Please verify input parameters... (SfxBaseModel::impl_store <file:///home/myuser/converte/docx/test.pdf> failed: 0x507(Error Area:Io Class:Access Code:7) at /home/buildslave/source/libo-core/sfx2/source/doc/sfxbasemodel.cxx:3207 at /home/buildslave/source/libo-core/sfx2/source/doc/sfxbasemodel.cxx:1783)

My setup does not have JRE installed and still works fine with older versions

Appreciate any help. Thanks!

Note that this is unrelated, and is just a warning.

This is ERRCODE_IO_ACCESSDENIED failure when writing - make sure you have the correct permissions, and that your LibreOffice does not run in some containerized environment (was your previous version installed e.g. from Apt, and the newer from Snap? That could explain why the former had access to some location that is not accessible for the latter).

@mikekaganski thanks for the response

I tried running the command as sudo, that worked for the .docx file, but for the .txt file it gave out a different error:

Error: Please verify input parameters... (SfxBaseModel::impl_store <file:///home/myuser/converte/docx/test.pdf> failed: 0xc10(Error Area:Io Class:Write Code:16) at /home/buildslave/source/libo-core/sfx2/source/doc/sfxbasemodel.cxx:3207 at /home/buildslave/source/libo-core/sfx2/source/doc/sfxbasemodel.cxx:1783)


This is a fresh installation on a new image so the previous version shouldn’t have any effect on the new one.

… which you called using exactly which command?

Same command as the one for docx, I just changed the file name
libreoffice7.4 --headless --convert-to "pdf:writer_pdf_Export" "/home/myuser/converte/docx/test.txt"

For reference I install using dpkg -i <libreoffice_tarfile>

A problem trying to overwrite existing PDF named test.pdf from the previous test with test.docx?

I see this locally, checking

Tried removing test.pdf and also by using the --outdir option, it gives the same error for the .txt file

This is a regression. Please file a bug report.

Wrote one
thanks! will stick with 7.3 for now