LibreOffice Calc 7.5 refuses to save as Unified Office Format .uos

Not sure if some other issue is involved, this seems to have changed immediately after updating to 7.5 a day ago. I normally save my .ods files as .uos and .xlsx in case I need to send them elsewhere. It refused to write the ‘file.uos’, so I renamed the existing ‘file.uos’ to ‘file_back.uos’ to no avail and ‘file.ods’ refuses to save as ‘file.uos’. It will not work if I try to save ‘file.xlsx’ Save As… ‘file.uos’, so it doesn’t appear to be the contents.

Error saving the document ‘file’:
Write Error
The file could not be written.

One more thing. If I close the ‘file.ods’ and go to File Open and select [Spreadsheets], it does not recognize the ‘file_back.uos’ as a spreadsheet type.

If I manually select from [All files] ‘file_back.uos’ to load it, I get:
General Error.
General input/output error.

It almost seems like someone tried to remove this spreadsheet format and didn’t get it ‘quite right’.
(being polite)

LibreOffice Calc:
Version: (X86_64) / LibreOffice Community
Build ID: 36ccfdc35048b057fd9854c757a8b67ec53977b6
CPU threads: 6; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

Kernel: 5.15.0-76-generic x86_64 bits: 64 compiler: gcc v: 11.3.0 Desktop: Cinnamon 5.6.8
tk: GTK 3.24.33 wm: muffin dm: LightDM Distro: Linux Mint 21.1 Vera base: Ubuntu 22.04 jammy
Type: Desktop Mobo: MSI model: 760GM-P23(FX) (MS-7641) v: 3.0 serial:
BIOS: American Megatrends v: 17.17 date: 04/22/2015


Still not working after kernel update (probably unrelated) and reboot. Tried renaming it and saving it to an external drive.
Unable to save as ‘file.uos’.
Same errors.

Works with:

Version: / LibreOffice Community
Build ID: 40(Build:2)
CPU threads: 1; OS: Linux 5.14; UI render: default; VCL: gtk3
Locale: es-MX (en_US.UTF-8); UI: en-US
Calc: threaded

I can’t test with version 7.5 on Linux; will try on Windows later.

I can save, and reopen, a little file (9 KB as .ods, 17 KB as .uos) using:
Version: (x86) / LibreOffice Community
Build ID: 9f56dff12ba03b9acd7730a5a481eea045e468f3
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: es-MX (es_MX); UI: es-ES
Calc: threaded

With a larger file (397 KB as .ods), the .uos could not be saved (LibreOffice becomes unresponsive for more than 120 minutes, and I killed the process).

Version: (x86) / LibreOffice Community
Build ID: 776eaf34564cbf3f034a0ba1fd1d5c32ff9ccf1c
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: es-MX (es_MX); UI: es-ES
Calc: threaded

…a little file occupies 9 KB as .ods, and 23 KB as .uos. I can open the file without problem.
While trying to save a larger file, LibreOffice crashed.

But the .uos file becomes saved (2390 KB), and I could open it latter. The original .ods file occupies 69 KB.

Try with a temporary user profile, LibreOffice user profile - The Document Foundation Wiki

Thanks will do after some sleep.

Could not save one of my .ods-files as .uos with (x86) and Win10 pro.
Got a “Schreibfehler. Datei konnte nicht geschrieben werden”, wich will be the same as a “general input/output error”.
No file was created. Other format was possible (.fods) in the same place.
I recommend a bug report at Bugzilla.

I can open a blank spreadsheet and Save as… “test.uos” without problems.
If I then open my spreadsheet I’m trying to Save as… “file.uos” and then try write it to a new name or external drive, it fails with the same error. I’m now starting to wonder if the file contains something that format is unable to translate.

The file contains text, dates, times and phone numbers.
Past events have been changed to purple text.
Every other event is either ‘no-fill’ background or a shade of grey to act as dividers.
All events are Liberation Sans 10pt except one column the text is 20pt.
It’s just now at row 80 and column Q with a 34.2k file size.

I will attempt to try chopping the file in question up a bit to see if it’s size related, otherwise, nothing has changed since it used to work with the previous version (lost info).

To: LeroyG.
Probably the best. There must be something that won’t “translate” in the file formats.

So, a quick update.
I was able to save a blank dummy file Save as… ‘test.uos’ without issue.
I was able to save a different, much larger file as ‘.uos’ without issue.
So, it has to be something out of sorts in the file that refuses to save.

an update to this issue…
It persists through LibreOffice
I started removing all cell borders and it still didn’t save as UOS.
In the end, I also removed all direct formatting and then it did save.
The only direct formatting I used was as follows:
Vertical Centering whole spreadsheet
Automatic Word Wrap - select columns
Left Justification - select columns
Horizontal Centering - select columns
Bold - select columns.
Font Color - select rows
Background Color - select rows
Cell Format Date as Mon/15/23 (example) - select columns
Cell Format Decimal 1,000.00 - select columns
Cell Format Time as hh:mm

Guess I will have to try restoring each of these then saving to find out what the offending feature is. Will post an update asap.

Final determination:
Setting a row as BOLD causes the save to fail.
I can select a cell and set it to BOLD and no problem.
I can set all the columns BOLD one at a time and no problem.
I can select the entire spreadsheet and set it to BOLD and no problem.
If I select a row and set it to BOLD, the spreadsheet refuses to save as .UOS.

No other formatting seems to affect the ability to save in .UOS format.
I’m done here.
Thank you for your patience.

Dear LibreOffice, please fix this annoying issue.
Thank you in advance.

1 Like

See final post and thanks.

There is a process - Reporting bugs

Thank you on it now!

Seems to be tdf#157712

1 Like

Been there, done that and BOOM! (thanks) :stuck_out_tongue:

Saving the file as a .UOS under appears to work properly.

I’ll consider this actually SOLVED for the time being.
Thanks to all,

The bug mentioned is untouched though, so this actually works with an entire row formatted to bold?

Re. Calc v7.5.4.2 and v7.6.2.1
Using 7.5 open the working .xlsx copy of this file

  • save as .uos - FAIL
    Using 7.6 open the working .xlsx copy of this file
  • save as .uos - PASS
    Using 7.6 open the working .xlsx copy of this file
  • select a row (already bold)
  • click bold
  • click bold (text is normal)
  • click bold (the entire row is now bold again)
  • save as .uos - pass
    Using 7.6 open the new .uos
  • pass

Using 7.5 open the new .uos

  • I get a “general read failure”…(repeatable)
  • hmmm

My dad used to say,
“If it’s not one thing, it’s a whole bunch of things.”
Seems to apply to programming quite well. :stuck_out_tongue:

Side Note:
The only reason I became aware of this issue, is when I tried to make backups in multiple “universal” formats of a critical file. It’s the transportation log/schedule for my wife’s medical trips with her transportation service. We found out in Feb/March of this year that she had cancer. After 33 radiation treatments and 4 rounds of chemotherapy, things are looking up.

But, we are now on trip 67 with 4 more trips scheduled.

You can probably imagine heads exploding if this data were lost or corrupted. So I keep three “universal” formats on 2 computers, 1 external hard drive and 1 Samsung micro flash memory card.