LibreOffice Calc Inserts Dates Not in Range

I created a spreadsheet with two columns: Date and Amount. The date column contains a list of dates for all the weekdays in August 2023. If I recall correctly I used a feature in LO Calc, I don’t remember which one or how, to fill in the cells of the date column so as to include only weekdays. That worked fine but when I selected the two columns date and amount, then Insert/Chart and chose a columnar chart the resulting chart has all of the weekend dates added to it even though they don’t exist in the date column. This creates blank columns on the chart and isn’t what I want.

Why does LO add weekends to the chart and what’s the best way to fix it?


LO, Mac


Thanks for trying to help but I really have no idea what to do with the screenshot you sent. I don’t have a clue where to find that dialog box or what to do when I get there. Rather than a solution I find I now have additional questions. :-/

Double click the chart
Right click in the x-axis area
Choose Format axis
Select the Scale tab

Read Editing chart axes


Double-click on the chart… double-click on the x-axis and choose Text instead Automatic:


It was →Sheet→Fill Cells → Fill Series right!?


Perfect. Thanks!

Thanks! That does it.

Yes, that must have been it. Thanks again!

Please do not add repeated comments, but edit your last comment instead.
Click … three dots and then the pencil icon.

When someone makes a comment to which I wish to reply I click the Comment icon and reply to them. This is how it seems to work on every other forum I belong to. It’s different here?

How do people know what you are responding to if all your responses to various people or posts of posts are contained in one post?

How do people know you are responding to them if you do not indicate to whom you are responding? For example, I don’t know if one of your comments was intended for me. However had you done e.g.
@robleyd Perfect. Thanks!
@karolus Thanks! That does it.
it would be clear to all.

This board is different than others I belong to. Elsewhere, when I respond to somebody I can choose to quote them by clicking “quote”. Thus, it’s obvious I am responding to them. It seems that option is missing here. I’ve never had to use the “@xxx” format anywhere else. It’s unfamiliar and confusing to me in part because people responding to me didn’t use “@RussG”. So, it seems inconsistent to me that I should need to use “@xxx” when responding to them when they didn’t use that format to respond to me. I can’t make sense of it. I don’t have this problem on other boards.

To answer your question “How do people know you are responding to them if you do not indicate to whom you are responding?” I know you responded to me because I got an email telling me so and because your post appeared right under mine in chronological order. How did you know I was writing to you?

If I make an OP and person #1 replies then I wish to say thanks or something else, my OP will be at top, person #1’s reply under that and my thanks will be third in line (I assume).

What if person #2 replies to my OP? Their post will be fourth in line. Right? If I thank them, and do so by editing my post #3 where I thanked the first person, then will my thanks to person #2 appear above their reply to me instead of below it. How are people supposed to keep track if posts and replies are scattered around the page out of order? How does this work? I’m sure there is some logic to it but I certainly don’t see it.

This isn’t a “board” or forum as you are probably used to. Please see This is the Guide…

It’s not. You select the text you want to quote and then Quote or hit q key.

Thanks, that’s a nifty trick. I’ve never seen that before and I’ve belonged to many boards over more years than I care to remember.

And thanks for the link you provided above to the guide. I recently looked for such a guide and could not find it. Obscurity seems to be one of LO’s features, LOL.

BTW, I am very grateful for LO, it’s programmers and forum members for the help I’ve received, and I have in the past donated to the cause.