LibreOffice doesn't recognize extension .ods

Using XP, LibreOffice does not recognize extension ods. When I try to open a calc document from the My Documents list, I am referred to a Windows help page for extension identification. The program also fails to place a shortcut to the document in the Recent Documents list. To access the calc file, I have to open the LibreOffice program, go to File, and open the document from there. I am using the latest program version, I believe, inasmuch as I downloaded it from Kim Komando yesterday (04/15/13). This calc document was created with Open Office. Everything worked flawlessly with that program.

I am using LibO on XP Prof/SP3 and a double click opens ods and other LibO files.

Which version of LibO are you using?

Did you reset your user profile?

This looks like Windows XP problem not having associated .ods file with LibreOffice. This problem should be solved during installation of LibreOffice. However now try this:

  1. Open Windows Explorer.
  2. Menu Tools | Folder Options.
  3. File Types tab.
  4. Click New button.
  5. In File Extension type in ods and select Associated File Type to “Spreadsheet OpenDocument” (or something similar, I got this data displayed in my native non-English language).

Hope this helps.

In my humble opinion, if double clicking a file in Windows does not open a LibreOffice then this has nothing to do with LibreOffice, but a problem at Windows that can’t associate file type to appropriate program (in this case LibreOffice). So any change (like resetting profile) in LibreOffice will not have any effect at running a program from Windows.

Not an answer, just my feedback.

I’m working on windows 7. I’ve worked with openoffice till yesterday, so I’m plenty of ods files. Then I installed LO, and I can open .ods files.

So +1 to froz’s answer (I don’t have sufficient reputation points yet to vote froz’s answer!)

Hope this helps

now you have some karma!

You could use the → Repair option of the LibreOffice installer.

The reason LO is not recognizing the file is because the file type is not associated with the application in this case .ods file to be opened with LO.

To do this manually:
1 ) right click on the file > scroll down to Open With option click the option , a new dialogue box opens up search and point (select) the Program in this case LO ,

make sure the check box:"Always use selected program to open this kind of file is checked and click ok at the bottom.

Thats it! Now your .ods files have been associated with LO and just double clicking will cause Xp to open the .ods file with LO by default.

n.b. if in any case you can’t locate LO , you should click browse and locate the LO “exe” file from there (in your installation directory)

 -alternatively to locate the LO "exe" : do a windows search  for it (default :"C:\Program Files\LibreOffice 4\program"    navigate to "scalc.exe"   or "soffice.exe" ) 

To help you out Screenshots from a test case on my WinXP system:

[001openWith.PNG - Google Drive]

[002selectProg.png - Google Drive]

ps. for some reason can’t see the paperclip icon in here to attach the screen shot images directly so i’m including links to them on my gdrive . hope this helps you. thx for reading.