LibreOffice hangs on startup

Oops! Just noticed that I entered the LibreOffice version number incorrectly. For the record, I’m using LibreOffice x86_64 version 5.2.1.2. Sorry for any confusion!

Unfortunately, I don’t yet have enough karma to edit my original post with updates. :frowning: I noticed that release 5.2.2.2 was released today, so I have that a try. No luck… Has anyone else had prolonged success with the 64-bit Windows version of LibreOffice 5.2.1 or 5.2.2? For former did work for me initially. Maybe it was a Windows update that broke it?

You may have more luck disabling OpenCL

Open a terminal and run: SAL_DISABLE_OPENCL=1 soffice and from the Tools → Options → OpenCL config area, disable use of OpenCL. Should start normally after that.

I have the same problem on many computers at work. LibreOfiice hangs at startup, showing a white screen.

I did try all the thing you did (reset profile, add registry key, remove/reinstall, etc…) but nothing works. The only way to still use LibreOffice is to rollback to version 5.0.6.

Here is my opengl_device.log :

DriverVersion: 9.17.10.3190
DriverDate: 5-20-2013
DeviceID: PCI\VEN_8086&DEV_0102&SUBSYS_11B91734&REV_09
AdapterVendorID: 0x8086
AdapterDeviceID: 0x0102
AdapterSubsysID: 0x11b91734
DeviceKey: System\CurrentControlSet\Control\Video\{370D5BC5-5F1A-426B-950B-B7D60234B2B0}\0000
DeviceString: Intel(R) HD Graphics

And my dump.ini

OpenGLVendor=0x8086
OpenGLDevice=0x0102
OpenGLDriver=9.17.10.3190
UseOpenGL=false

One possible difference between what you’re seeing and me: I just see the startup logo, and not a white screen. Otherwise, it’s just as useless. I haven’t tried downgrading yet, but that’s definitely what I’m going to try next. Thanks for the suggestion!

Time for an update - and a workaround.

I just tried the latest 5.2.4.2 release - 64-bit - and I still have the same problem: every application hangs on startup after displaying the LibreOffice logo. (Just stating this once more for those who jump to conclusions: it’s not an OpenGL issue.)

So, I tried the 32-bit version and guess what? It works without any problem! The workaround is to use 32-bit LibreOffice and avoid the 64-bit version for the time being - if you have this problem.

It seems to be too trivial to blame 64-bit code for the problem, but - as others have pointed out - the 32-bit version works while the 64-bit version hangs on application startup, on some machines at least. Just to recap, I did a number of clean installs of the 64-bit version and disabled OpenGL, so this is not a registry/configuration/OpenGL issue.

As this is an unsatisfactory conclusion, I have also raised bug report 105084:

This works… 32bit version works, 64bit version freezes. Unfortunately I can’t upvote, needs 5 points.

Hi.
I have this problem in opensuse.
I remove config file in path ./config/libreoffice

Perfect. That worked for me! Thanks!

Someone please upvote this - FINALLY a solution that worked for me!

Running -

  • /opt/libreoffice6.3/program/soffice
  • — resulted in the splash logo, and the load thermometer hung about 50%
  • /opt/libreoffice6.3/program/soffice --convert-to pdf --outdir /tmp --headless test.odt
  • — Just hung

I renamed the whole : ~/.config/libreoffice/

And both now work fine.

Many thanks, Ian
.

Reset your user profile. See Frequently asked questions - General - The Document Foundation Wiki - important: rename the folder, don’t delete it.

EDIT If that doesn’t help, try a repair install. (Run the install file and choose repair install when that option is offered.)

EDIT 2 You might try to start Windows in safe mode and see if LibreOffice runs then to make sure there isn’t some software conflict.

Maybe there’s a bad registry entry. When you have uninstalled Libre, clean up the Windows Registry - find all instances of Libre that the uninstall didn’t remove and delete them yourself. Then do a re-install.

If this answer helped you, please vote it with :heavy_check_mark: (here on the left). That will help other people with the same question.

Thanks. I did try resetting my profile, but no luck.

I already tried the repair install as well. No luck there either.

I’ll give rebooting in Safe Mode a try - but that seems like a long-shot. I was using LibreOffice perfectly well until one day when nothing worked anymore, and I don’t believe I’ve updated any drivers in-between it working and not working, but who knows?

I did clean the registry after uninstalling, removing all LibreOffice/OpenOffice references, then reinstalling, but that didn’t do the trick. FWIW, I also cleaned out the filesystem as well. But it has to be something like that… :frowning:

It has to be something on your system, because it isn’t crashing on most other computers. Any other system scans? hard disk running fine? I once had trouble with a program that sat on a bad sector on the hard disk.

Sorry for the delay responding. I’ve checked the disk and there’s no bad sectors.

Safe Mode didn’t work, BTW.

Please test replacing your registrymodifications.xcu that is in the root of the user profile, it has the OpenGL disable.

registrymodifications.ods

I have change to extension to ods to upload here, change the extension to xcu after download it.

Thanks for the file. I didn’t replace my own file with the one you provided, because it included a number of settings that weren’t applicable to my machine. But I did copy over the OpenGL related settings (ForceOpenGL and UseOpenGL). Unfortunately, that didn’t do the trick. Do I need any others?

This is a particularly puzzling problem, because I’ve been using LibreOffice (and OpenOffice before that) for many years on this same laptop with no issues whatsoever. Now nothing works… :frowning:

FWIW, the AppData\Roaming\LibreOffice\4\crash directory contains a file called “dump.ini” that contains the following (each time I attempt to run, say, Writer, another identical block is added to the file):

OpenGLVendor=0x8086
OpenGLDevice=0x0126
OpenGLDriver=9.17.10.4229
UseOpenGL=false

That hasn’t changed (I got the same output before adding the OpenGL settings you mentioned to my registrymodifications.xcu file), so I suspect that OpenGL isn’t the problem.

There’s also an AppData\Roaming\LibreOffice\4\cache\opengl_device.log file which contains the following:

DriverVersion: 9.17.10.4229
DriverDate: 5-27-2015
DeviceID: PCI\VEN_8086&DEV_0126&SUBSYS_04941028&REV_09
AdapterVendorID: 0x8086
AdapterDeviceID: 0x0126
AdapterSubsysID: 0x04941028
DeviceKey: System\CurrentControlSet\Control\Video\{469D7B61-9868-45D9-B476-E1C84DBD22BB}\0000
DeviceString: Intel(R) HD Graphics 3000

Hope that helps…