LibreOffice hangs on startup

One possible difference between what you’re seeing and me: I just see the startup logo, and not a white screen. Otherwise, it’s just as useless. I haven’t tried downgrading yet, but that’s definitely what I’m going to try next. Thanks for the suggestion!

Time for an update - and a workaround.

I just tried the latest 5.2.4.2 release - 64-bit - and I still have the same problem: every application hangs on startup after displaying the LibreOffice logo. (Just stating this once more for those who jump to conclusions: it’s not an OpenGL issue.)

So, I tried the 32-bit version and guess what? It works without any problem! The workaround is to use 32-bit LibreOffice and avoid the 64-bit version for the time being - if you have this problem.

It seems to be too trivial to blame 64-bit code for the problem, but - as others have pointed out - the 32-bit version works while the 64-bit version hangs on application startup, on some machines at least. Just to recap, I did a number of clean installs of the 64-bit version and disabled OpenGL, so this is not a registry/configuration/OpenGL issue.

As this is an unsatisfactory conclusion, I have also raised bug report 105084:

This works… 32bit version works, 64bit version freezes. Unfortunately I can’t upvote, needs 5 points.

Hi.
I have this problem in opensuse.
I remove config file in path ./config/libreoffice

Perfect. That worked for me! Thanks!

Someone please upvote this - FINALLY a solution that worked for me!

Running -

  • /opt/libreoffice6.3/program/soffice
  • — resulted in the splash logo, and the load thermometer hung about 50%
  • /opt/libreoffice6.3/program/soffice --convert-to pdf --outdir /tmp --headless test.odt
  • — Just hung

I renamed the whole : ~/.config/libreoffice/

And both now work fine.

Many thanks, Ian
.

Reset your user profile. See Frequently asked questions - General - The Document Foundation Wiki - important: rename the folder, don’t delete it.

EDIT If that doesn’t help, try a repair install. (Run the install file and choose repair install when that option is offered.)

EDIT 2 You might try to start Windows in safe mode and see if LibreOffice runs then to make sure there isn’t some software conflict.

Maybe there’s a bad registry entry. When you have uninstalled Libre, clean up the Windows Registry - find all instances of Libre that the uninstall didn’t remove and delete them yourself. Then do a re-install.

If this answer helped you, please vote it with :heavy_check_mark: (here on the left). That will help other people with the same question.

Thanks. I did try resetting my profile, but no luck.

I already tried the repair install as well. No luck there either.

I’ll give rebooting in Safe Mode a try - but that seems like a long-shot. I was using LibreOffice perfectly well until one day when nothing worked anymore, and I don’t believe I’ve updated any drivers in-between it working and not working, but who knows?

I did clean the registry after uninstalling, removing all LibreOffice/OpenOffice references, then reinstalling, but that didn’t do the trick. FWIW, I also cleaned out the filesystem as well. But it has to be something like that… :frowning:

It has to be something on your system, because it isn’t crashing on most other computers. Any other system scans? hard disk running fine? I once had trouble with a program that sat on a bad sector on the hard disk.

Sorry for the delay responding. I’ve checked the disk and there’s no bad sectors.

Safe Mode didn’t work, BTW.

Please test replacing your registrymodifications.xcu that is in the root of the user profile, it has the OpenGL disable.

registrymodifications.ods

I have change to extension to ods to upload here, change the extension to xcu after download it.

Thanks for the file. I didn’t replace my own file with the one you provided, because it included a number of settings that weren’t applicable to my machine. But I did copy over the OpenGL related settings (ForceOpenGL and UseOpenGL). Unfortunately, that didn’t do the trick. Do I need any others?

This is a particularly puzzling problem, because I’ve been using LibreOffice (and OpenOffice before that) for many years on this same laptop with no issues whatsoever. Now nothing works… :frowning:

FWIW, the AppData\Roaming\LibreOffice\4\crash directory contains a file called “dump.ini” that contains the following (each time I attempt to run, say, Writer, another identical block is added to the file):

OpenGLVendor=0x8086
OpenGLDevice=0x0126
OpenGLDriver=9.17.10.4229
UseOpenGL=false

That hasn’t changed (I got the same output before adding the OpenGL settings you mentioned to my registrymodifications.xcu file), so I suspect that OpenGL isn’t the problem.

There’s also an AppData\Roaming\LibreOffice\4\cache\opengl_device.log file which contains the following:

DriverVersion: 9.17.10.4229
DriverDate: 5-27-2015
DeviceID: PCI\VEN_8086&DEV_0126&SUBSYS_04941028&REV_09
AdapterVendorID: 0x8086
AdapterDeviceID: 0x0126
AdapterSubsysID: 0x04941028
DeviceKey: System\CurrentControlSet\Control\Video\{469D7B61-9868-45D9-B476-E1C84DBD22BB}\0000
DeviceString: Intel(R) HD Graphics 3000

Hope that helps…

Hi

May be you chan check the registry. See the attachment in tdf#93546

Regards

Thanks for your contribution. I added the specified registry entries - no luck.

These entries basically do the exact same thing that the answer from m.a.riosv suggested in the registrymodifications.xcu file, and they didn’t work either.

I don’t believe that this is an OpenGL-related issue.

In my situation, the problem was related to system proxy settings (it’s set to detect proxy settings automatically). At first, I disable auto detection in system settings. After that LibreOffice starts correctly. Next, I set Proxy server to none in LibreOffice settings and return system settings back.

1 Like

I have the same problem. Version 7.1.0.3 x64 did install without errors. When trying to start it hung on a ‘final’ splash screen, no errors. I left it for about 8 hours, no changes. After killing the task i then uninstalled it and reinstalled it, same persisting problem. I then tried the 7.0.3 x64 version, same probem, also hung on the final splash screen.

I then tried the 7.0.3 x32 version of Libreoffice. It took a little time, but Writer did start after a about a minute. I noticed some things were setup by Writer after starting it the first time and prior to getting the main Witer window. The second time i started Writer it started quite fast. So there is some sort of post install preparation being done at first time start.

I then started the 7.1.0.3 x64 installer again. It removed parts of the previous 7.0.3 x32 installation and then installed without error. I then started Writer, and it started immediately, no errors, no problems. My best educated guess is that the x64 versions of LibreOffice installer has post installation and pre first time run setup issues which causes LibreOffice to hang on the splash screen.

Other users seem to confirm that the problems seems to be related with the user profile that is being setup by LibreOffice x64. Perhaps my experience can point you to a solution for the x64 installers.

My Windows 10 version is the latest 20H2 version, Build 19042.804, with minimal application setups and all updates applied. Some of the hardware drivers, like for the videocard, are outdated (2016) as this is a HP Pavillion DV7 laptop which has switchable graphics between Intel HD 3000 and AMD Catalyst 15.7. The OpenGL Extension viewer 5.02 reports version 3.1 of OpenGL, the latest 6.18 version simply crashes when querying the Intel HD Graphics 3000 videocard.

So for now, install the x32 version, then upgrade to the x64 version.