LibreOffice hangs on startup

Please test replacing your registrymodifications.xcu that is in the root of the user profile, it has the OpenGL disable.

registrymodifications.ods

I have change to extension to ods to upload here, change the extension to xcu after download it.

Thanks for the file. I didn’t replace my own file with the one you provided, because it included a number of settings that weren’t applicable to my machine. But I did copy over the OpenGL related settings (ForceOpenGL and UseOpenGL). Unfortunately, that didn’t do the trick. Do I need any others?

This is a particularly puzzling problem, because I’ve been using LibreOffice (and OpenOffice before that) for many years on this same laptop with no issues whatsoever. Now nothing works… :frowning:

FWIW, the AppData\Roaming\LibreOffice\4\crash directory contains a file called “dump.ini” that contains the following (each time I attempt to run, say, Writer, another identical block is added to the file):

OpenGLVendor=0x8086
OpenGLDevice=0x0126
OpenGLDriver=9.17.10.4229
UseOpenGL=false

That hasn’t changed (I got the same output before adding the OpenGL settings you mentioned to my registrymodifications.xcu file), so I suspect that OpenGL isn’t the problem.

There’s also an AppData\Roaming\LibreOffice\4\cache\opengl_device.log file which contains the following:

DriverVersion: 9.17.10.4229
DriverDate: 5-27-2015
DeviceID: PCI\VEN_8086&DEV_0126&SUBSYS_04941028&REV_09
AdapterVendorID: 0x8086
AdapterDeviceID: 0x0126
AdapterSubsysID: 0x04941028
DeviceKey: System\CurrentControlSet\Control\Video\{469D7B61-9868-45D9-B476-E1C84DBD22BB}\0000
DeviceString: Intel(R) HD Graphics 3000

Hope that helps…

Hi

May be you chan check the registry. See the attachment in tdf#93546

Regards

Thanks for your contribution. I added the specified registry entries - no luck.

These entries basically do the exact same thing that the answer from m.a.riosv suggested in the registrymodifications.xcu file, and they didn’t work either.

I don’t believe that this is an OpenGL-related issue.

In my situation, the problem was related to system proxy settings (it’s set to detect proxy settings automatically). At first, I disable auto detection in system settings. After that LibreOffice starts correctly. Next, I set Proxy server to none in LibreOffice settings and return system settings back.

1 Like

I have the same problem. Version 7.1.0.3 x64 did install without errors. When trying to start it hung on a ‘final’ splash screen, no errors. I left it for about 8 hours, no changes. After killing the task i then uninstalled it and reinstalled it, same persisting problem. I then tried the 7.0.3 x64 version, same probem, also hung on the final splash screen.

I then tried the 7.0.3 x32 version of Libreoffice. It took a little time, but Writer did start after a about a minute. I noticed some things were setup by Writer after starting it the first time and prior to getting the main Witer window. The second time i started Writer it started quite fast. So there is some sort of post install preparation being done at first time start.

I then started the 7.1.0.3 x64 installer again. It removed parts of the previous 7.0.3 x32 installation and then installed without error. I then started Writer, and it started immediately, no errors, no problems. My best educated guess is that the x64 versions of LibreOffice installer has post installation and pre first time run setup issues which causes LibreOffice to hang on the splash screen.

Other users seem to confirm that the problems seems to be related with the user profile that is being setup by LibreOffice x64. Perhaps my experience can point you to a solution for the x64 installers.

My Windows 10 version is the latest 20H2 version, Build 19042.804, with minimal application setups and all updates applied. Some of the hardware drivers, like for the videocard, are outdated (2016) as this is a HP Pavillion DV7 laptop which has switchable graphics between Intel HD 3000 and AMD Catalyst 15.7. The OpenGL Extension viewer 5.02 reports version 3.1 of OpenGL, the latest 6.18 version simply crashes when querying the Intel HD Graphics 3000 videocard.

So for now, install the x32 version, then upgrade to the x64 version.