Libreoffice locks clipboard -- CTRL+C CTRL+V not working

Attempting to Copy’n’Paste a text string from Notepad to in Windows 10, without success.

Restarting releases the lock, and a Copy’n’Paste is attempted from same open Notepad-window to Microsoft Edge browser with success.

A now restarted takes the same Clipboard content into a Calc spreadsheet cell. Without ever needing to restart Win10.

I think there must be a bug in and how it locks the Clipboard in Win10?

Never claim a bug unless you have thoroughly tested a program. The bug is yours: that you use microsoft’s crap instead of a good operating system. LibreOffice works without any problem on openSUSE Linux 13.2.

I have this problem all the time on openSUSE 42.1.

Alright, you have a valid point. However, I found the following suggestion when googling for a resolution: “There’s probably an app that’s “locked” the clipboard. Try and work out what app has done that and close it.” Source:

So what I am suggesting is that LibreOffice does not communicate with the Clipboard properly?

Here is an additional information regarding the incident. I was able to perform a whole lot Cut’n’Paste, Copy’n’Paste, both before and after and in between the locked LibreOffice vs. Clipboard interaction. So between other programs on Windows 10 Copy’n’Paste worked flawlessly.

But LibreOffice Calc wouldn’t take that text string from the Notepad program, but rather the previous Clipboard selection was presented over an over again, without being overwritten when attempting pasting into Calc.

All the other programs didn’t care about that previous locked Clipboard element, that LibreOffice Calc was stuck on. It just bypassed that Clipboard element as if it was never there. Now I have described this incident even more clearly. I will leave it with you. If you want a better LibreOffice experience with Windows 10. Or maybe you can pinpoint the Windows 10 culprit then, if there excist such?

Today I experienced the issue again. However, this time it came on rapid (had just opened LO Calc document). And the issue was to Copy a text string from within a LO Calc cell and out to Microsoft Edge. However, when I tried again to copy it to a Notepad window it worked. Or else it just worked at the second attempt. Which I won’t know the true answer behind. Anyway I managed to copy the text string which was an URL into Edge from LO Calc cell via the Notepad window. It is SO bothersome…

Ok, I tried to do the same copying job again, from within LO Calc to Edge. But it didn’t replicate. I don’t know why. Maybe the previous copy job via Notepad and into Edge had flushed the lock? However. When you the malfunction do occur, then if you try to copy from the same cell OR copy into the same cell (maybe from Edge), then trying to do a CTRL+C over and over again fails.

Now I have the problem coming back, where I cannot Paste anything from externally into a LO Calc cell. But the Clipboard remembers the Copy when attempting Pasting the same info which is inside Windows Clipboard from external to external software without issues. Windows Clipboard behaves normal, but LO does not behave normal.

It appears there may be problems dealing with the clipboard in Win 10. Please see this post (click here) for more information.

Thank you. I am using LibreOffice version
Forgot to mention this important detail.

I don’t use any remote desktop third party software as one thread mentions tenfolds. This is a pretty clean installed Windows 10. That no one cares to attemp reproducing this bug, is a disaster. Such an elementary function, which should follow “Standard Windows” (copy’n’paste), SIMPLY MUST WORK out of the box for the software. Blame wars does not lead anywhere. Please elevate this as a serious bug? Ref:
Check comment 62

From what I understand, there is a change in Windows 10 which is causing some of the problems with copy/paste. From some of the bug reports it appears in different ways. The link given in my answer states a couple of items: I use Linux and cannot reproduce the problem; the originator of the question stated MS Edge was causing the problem. This is in your question. You should file/amend a bug report stating your circumstances.

Well, yes Edge was copy’n’pasted to as a follow up test. After reading the previous bug report from 2013, my impression is that this problem has propagated since OpenOffice as an heirloom, and on several Windows environments previous to before Edge even was made.

There is even av very vague comment 23 suggesting it can happen on Linux, but the three later comments regarding Linux claims the same as Ratslinger here says. It may not be reproducable in Linux.

For some it seems even hard to reproduce in a Windows environment. But other commentors from the Bug-thread claims you just have to do a couple of simple steps in the Windows environment. While other Windows users claim you have to do a whole lot of Copy’n’pasting before you succeed.

The simple steps version seem to say: 1. Copy’n’Paste within LO, then 2. try to Copy’n’Paste from outside another program into LO.

I attempted the simple steps test. Opened two Notepad windows. Did some small text string copying between them. Went into LibreOffice Calc, did some internal copying. Then I went back to one of the Notepad-windows, and attempted to copy a text string into a Calc cell. WITH success (today).
Now as an extra measurement, I attempted to copy a bit internally and from external, but this time from Edge as test 1 and from Chrome as test 2. WITH success (today).

I have edited this message: to WITH suc.

WITH success explaining that Copy’n’Paste worked this time.
I was thinking in relation to reproduce the error in the inital unedited posting.

WITH success explaining that Copy’n’Paste worked this time.
I was thinking in relation to reproduce the error in the inital unedited posting.

I don’t know if this analogy makes any sence. But: 1. You have a diesel engine. 2. The developers of the fuel made it a gel based fuel. 3. The gas station is Microsoft providing gel diesel fuel. LibreOffice is the diesel engine, feeding and fuel tank. 4. Somewhere on the way, since gel takes air bubbles, and since diesel feeding pipes needs to be bubble free for a flawless engine operation. It occasionally happens to come air bubbles in the fuel. 5. No-one wants the ownership of the fuel design.

What do you think is more likely to happen? 1. That MS takes responsibility for their flawed OS, with the chain of complexity it is to suggest another Clipboard function for all those excisting thousands of applications. Or 2. That LibreOffice developers takes an approach towards building around the Clipboard functions at hand?

Either way, if nothing is done about the issues. Then LO users may still continue seeing a malfunctioning Copy’n’Paste functionality. I think LO is a great open source