LO fails for email merge

Sorry for the length, but I’m trying to provide as much diagnostic
info as I can.

I’m trying to do email merge on an Ubuntu 22.04 laptop with LO
I started using this:

as a tutorial.

Everything goes well, including connection the the SMTP server under Test.

I then get to hitting the “Send E-mail Messages” button. This does nothing.
In particular, the tutorial says I should see an “E-Mail Merged Document” window
in which I can specify the column of the table containing email addresses for
the recipients.

This was started from a terminal window that shows stuff sent to stderr. I’ve yet
to find any other location for an error log, but I’m looking.

My second attempt started with directions in for LO 7:


Unfortunately, this doesn’t document merging emails. I winged it from
there. (Was merging emails ever tested? If so, why not documented?)

This got further because it had me led me down the File > Wizards > Address Data Source path, so the spreadsheet got converted into .odb format and got registered.

Now the “E-Mail Merged Document” window pops up for me to fill in To: and Subject:,
but when I click “Send Documents” I get a stay-on-top notification that “The connection to the outgoing server has been established” and that “0 of 3 emails sent”, but “Emails not sent:0”. The application is completely frozen at that point. The Details, Pause, and Cancel buttons are dead and the other LO offices are greyed out.

Did you fill in the email settings in Tools - Options - LibreOffice Writer - Mail Merge Email? Copy the settings from your email client (the settings in maths.cam.ac.uk are for their email system that presumably only their students and faculty can access). Note that Gmail can be problematic impossible with their authentication, see tdf#144379
See Mail Merge Email

As I said, I went through all the instructions, including setting up the smtp server and connecting to it through the Test button at the bottom of that window. When I attempted to send the messages, LO reported that it successfully connected to the server, but the messages just didn’t go.

This would be a lot more tolerable if error messages/logs were generated and if the whole thing just froze.

Maybe this comment from a previous question about starting from line 2 in the merge helps, Mail merge giving the message and hangs - #13 by sshipway

Thanks. Installing an old version is a clunky workaround, but
if it works. I prefer fixing problems rather than kicking the can
down the street.

I may try enabling debugging to try to track this down.

Actually the workaround by sshipway was to avoid “all rows” or starting with 1.
Have you tried to send a range like 3 to 8 ?


Look at e.g. tdf#148338, or tdf#148384. When there is a bug report, it has a chance to be fixed. No bug report → no chance.

There is tdf#102998, which is a mail merge meta, and it shows that the bugs get fixed gradually. Is your problem listed there as a blocker?

1 Like

Thanks. I’ll try it.

Tried it. No joy. Same dead status window and Writer
locks up solid.

That’s annoying, I’d hoped that there would be some fix in place now we’re in 7.3. The ‘give range 2-max’ solution worked in 7.2 and, of course, mailmerge worked fine in 6. If 7.3 it totally broken then it’s a good thing I haven’t needed it again in the last 6 months …

It could possibly be tdf#150188. It was/is relevant to 7.3.x, and reported to work OK with 7.4+. However, it is reported on Windows. If not that, I’d suggest trying a newer version, but on the second thought, indeed it can’t be that problem.