LOF 7.0 not starting (corrupt bootstraprc)

After LOF update to 1:7.0.1~rc2-0ubuntu0.18.04.1 (from PPA ppa.launchpad.net/libreoffice/ppa/ubuntu bionic, context is Ubuntu Mate 18.4.05, fully updated), I get a msgbox stating:

The application cannot be started. The configuration file /usr/lib/libreoffice/program/bootstraprc is corrupt

I’ve tried reinstalling, after a remove/purge, to no avail. bootstraprc contains:

 [Bootstrap]
 InstallMode=<installmode>
 ProductKey=LibreOffice 7.0
 UserInstallation=$SYSUSERCONFIG/libreoffice/4

and, fwiw, SYSUSERCONFIG is not defined.

Any suggestion is greatly appreciated, TIA.

bootstraprc “dump” reformatted by ajlittoz

Try purge all packages with “libreoffice” in names and then try install LibreOffice from official site

libreoffice.org/download

Hello, you could try the LO AppImage version, which does not require any installaiton. Just

  1. download the AppImage file

    wget ‘libreoffice.soluzioniopen.com/stable/full/LibreOffice-still.full-x86_64.AppImage

  2. Make it executable

    chmod +x LibreOffice-still.full-x86_64.AppImage

  3. And run it.

    ./LibreOffice-still.full-x86_64.AppImage

Easy as pie.

There are different “flavours” available see here:
https://www.libreoffice.org/download/appimage/

Hope that helps.


To show the community your question has been answered, click the ✓ next to the correct answer, and “upvote” by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!


Have a nice day and let’s (continue to) “Be excellent to each other!”


Ask / Getting Started:

https://wiki.documentfoundation.org/Ask/Getting_Started

Thanks for all the suggestions, but I’ve managed to return to nominal by simply removing (tilde)/.config/libreoffice.

First subsequent start regenerated all files within, and now it appears fixed.