[Meta] How to upload avatar image on AskLibO?

I cannot seem to be able to upload an avatar for myself on this site. I have tried with the latest Chrome (24.0.1312.52) on OS X (10.6.8) and Windows 7. I have tried several image sizes and formats (PNG, JPG, GIF). All I get is the same message:

Upload a valid image. The file you uploaded was either not an image or a corrupted image.

The problem with that is that there’s no information about what is an allowed image format and size. I suspect that the uploader is broken for my browser or something.

Hi @Nicd, Please file a bug about this problem against the website and post the bug here (use the format “fdo # XXXX”, without spaces). Once the bug’s in the system, I’ll nudge the QA team. Thanks!

The bug is filed as fdo#60108.

Okay. So what?..

@JohnSUN – Sorry that we haven’t fixed this problem yet. We’re still waiting for fdo#61098 to be resolved (Upgrading the Ask site software), and when that bug is fixed then hopefully we can move on to this one.

I apologize that there’s not much I can do. I’ll be pinging Florian and the Infrastructure team on March 26th for another update.

fdo#60108 · Status: RESOLVED FIXED

Hi @Nicd,

Update: per the report, fdo#60108 - ASKLIBREOFFICE: Uploading avatar in Ask LibreOffice fails is in the system with a status of NEW.

I’m still waiting to hear from the IT team about our incipient upgrade to the latest version of the Askbot software. I don’t have a schedule for the upgrade, so I can’t give an estimate on how long it will take to have them look at this bug. Sorry.

I’m going to resolve this question as BUG FILED. Please put all future comments/testing notes on the bug report.


The image I uploaded for my profile picture was a 431KB JPEG image, with dimensions of 1540x1540 and 8-bit color, so something smaller than those specs should hopefully work for you! I uploaded the image using Firefox on Ubuntu.

I haven’t heard of anyone else having avatar image-upload problems, but perhaps there’s some weird incompatibility with (the latest build of) Chrome? Could you please try using Firefox or another browser and reporting back?

Thanks for letting us know about this problem!

The assumption that Chrome is not working properly is not confirmed. IE 8.0 gives the same result.

Message received when trying to upload this file

JohnSUN's avatar

Really seems the image uploader is truly broken. I tried with Firefox 12 on OS X and did not succeed. I got the error in my first message a few times, and then the one in your image (internal server error).

I am using FireFox 19.0 and have been unable to upload an avatar.

I have tried a thumb-sized JPEG and a 8x6 JPEG.

I get the same error message as the Original Poster.