Missing certificates for document signing

Libre Office ver Version:
Build ID: 55b006a02d247b5f7215fc6ea0fde844b30035b3
Locale: en-AU (en_AU)

Windows 10 Latest

Did File/Digital Signatures/Sign Document

Got "Select Certificate you want to use for signing"

With a box to list my Certificates
Issued to | Issued by | Expiration Date

Blank box nothing listed in spite of the fact that I have verified via Chrome/Settings/Manage Certificates that I have valid Certificate in my Certificate store.

I have this too. And this seems to be the only page in the while internet that describes this, so I’m frustrated that there are no answers ;-(

I’m getting the same thing: I registered the dig cert with Firefox and Thunderbird, created a new doc, saved it, and tried to sign it but got a blank certificate. I’m using:

Build ID: 1:5.1.6~rc2-0ubuntu1~xenial3
CPU Threads: 8; OS Version: Linux 4.4; UI Render: default;
Locale: en-US (en_US.UTF-8); Calc: group

I have many certificates on my computer but the dialog shows only two; they are rather old and expired issued by the Tax Service. Under Firefox, they are listed on their own in an unusual tab (not Servers under which all others are listed, nor Authorities for root certificates). I don’t know where they are stored and since I have no idea about their filename, I could not locate them.

I think the issue is related to certificate file format, expecting other than PEM?

upgrade to libreoffice 6.4.3. See : Digital certificate does not appear on certificates list to sign a file in LibreOffice

Is this the same bug as tdf#92761?

I just rebooted my machine and tried signing a .odt text doc and it worked