My laptop’s dGPU (Nvidia) remains on when OpenCL is enabled

No matter what I do (even in the main menu when nothing is opened), the dGPU led remains on when LO is running. This obviously consumes more power.

Disabling OpenCL resolved this problem. Forcing soffice.exe and soffice.bin to use the iGPU (in Parameters) didn’t change anything.

Is it possible to have OpenCL not use the dGPU ? There are OpenCL allow and deny lists in the advanced parameters, the allow list contained “//Nvidia Corporation//” by default, so I moved it to the deny list instead, but it didn’t change a thing. Then I’ve reset all LO parameters, didn’t change anything either.

Now the values are :

  • OpenLCAllowList = //Advanced Micro Devices, Inc\.//,//Intel\(R\) Corporation//,//NVIDIA Corporation//,Linux//Advanced Micro Devices, Inc\.//1445\.5 \(sse2,avx\)
  • OpenCLDenyList = Windows//Intel\(R\) Corporation//3\.0\.1\.10891,Windows//Intel\(R\) Corporation//4\.2\.0\.99,Windows//Intel\(R\) Corporation//5\.2\.0\.10049,Windows//Intel\(R\) Corporation//9\.17\.10\.2884

While I don’t really need OpenCL for now (hence disabling it isn’t much of an issue for me), I wonder if it’s possible to get more control over what GPU OpenCL uses…

Any ideas ?

You might be able to choose in the nVidia dialogue, see Why does LO use discrete graphics, not integrated? - #4 by Regina

You could also try this, click Tools > Options > View and tick Force Skia software rendering or untick Use Skia for all rendering

Thanks for your reply !

Forgot to mention it, but Force Skia software rendering (that was already ticked strangely, so I unticked it) and Use Skia for all rendering were the first things I tried, with no more luck.

I checked the thread you mentioned, the OP says his problem was solved by unticking “Use OpenGL for all rendering” (though it doesn’t really reply to the question in the subject), there’s no such option any more but there’s a DisableOpenGL property that’s set to false. Setting it to true and reenabling OpenCL brings the problem back, so for now disabling OpenCL remains the only working solution.

I’m wondering if it could mean that OpenCL support is missing on the Intel side, but is present on Nvidia. On Intel’s site, the Graphics Compute Runtime for OpenCL driver is said to be included with the graphics driver package for Windows, so it should be there, but who knows…

I referred directly to Regina’s comment on changing the settings in Control Panel\All Control Panel Items\NVIDIA Control Panel

I am guessing here because, according to Task Manager, LibreOffice on my laptop always uses the integrated graphics Intel UHD Graphics 620, not the nVidia MX150

BTW I guess OpenLCAllowList is just a typo on this site and not in the list

(@EarnestAl I didn’t reply directly to your answer because doing so disables paragraphs, hence making the posts more difficult to read)

Ah yes, the post you referred to is from 2018, at that time, mentioning the global preferences for GPU selection used to imply the Nvidia control panel, but nowadays it’s possible to do that in Preferences => System => Display => Graphics, which I think overrides the Nvidia control panel. However, the autoselection preferences are still available in Nvidia’s CP, I tend to think they’re useless now and here for historical purposes only, anyway I tried (soffice.exe and soffice.bin set to Integrated Graphics), it doesn’t work either.

That being said, I finally solved this problem, somehow, by setting the OpenCLAllowList property value to //Intel \(R\) Corporation// (and nothing else). Now it uses the integrated graphics…

Why “somehow” ? Because everytime I minimize LO or switch to another window, there must be some useless probing and the dGPU switches on again for around 15 seconds. That’s why I hesitate to mark this as a solution, imho it should not switch on/off like that. Plus, LO boots much faster with OpenCL off anyway.