No response from command prompt during convert ODT to PDF


Question: how to convert ODT to PDF using commandpromt.
Examples below don’t do anything. no convertion and no error message.
i’m using libreoffice-common: LibreOffice 420m0(Build:2)
on Ubuntu 14.04

i have tryed:
soffice --headless --convert-to pdf /path/to/file.odt
soffice --headless --convert-to pdf:writer_pdf_Export /path/to/file.odt
soffice --headless --convert-to pdf --outdir /path/to /path/to/file.odt

none worked. but even stranger, none displayed an error… or any type of output.
so i read about some error with /tmp/LibO_Conversion here: How to NOT connect to a running instance
so i tryed:
soffice "-env:UserInstallation=file:///tmp/LibO_Conversion" --headless --convert-to pdf /path/to/file.odt
even deleting the directory using FTP

i have installed Libreoffice-common, and after some trying also installed Libreoffice-writer.
nothing worked.

ps. also tryed lowriter --headless… and libreoffice --headless
ps2. also tryed /usr/bin/soffice --headless

--backtrace gives:
warning: Currently logging to gdbtrace.log. Turn the logging off and on to make the new setting effective.
[Thread debugging using libthread_db enabled]
Using host libthread_db library “/lib/x86_64-linux-gnu/”.
[New Thread 0x7fffe0bc5700 (LWP 16720)]
[New Thread 0x7fffdf3c4700 (LWP 16721)]
[Thread 0x7fffdf3c4700 (LWP 16721) exited]
[Thread 0x7fffe0bc5700 (LWP 16720) exited]
[Inferior 1 (process 16716) exited normally]
/usr/lib/libreoffice/program/gdbtrace:9: Error in sourced command file:
No stack.

Could you please rewrite your problems into (a) question(s)? Please surround commands with backticks so that they are clearly marked. Where did you read about some error with /tmp/LibO_Conversion, what did it read? Why did you delete the directory using FTP? Thanks!

Please edit the question to indicate: LO version and Java version. Ensure no instance of LO is already running. Also try using the full path to soffice and changing into the directory of the ODT to be converted. The first provided example should work.

@bencomp I have read about the /tmp/LibO_Conversion at How to NOT connect to a running instance

@oweng not mentioned but also tryed. changed to the directory where the ODT file was. then used soffice --headless --convert-to pdf *.odt still nothing.

@oweng do i need java on a ubuntu server using libreoffice headless?? if so. can it be openjdk 7 headless?

@NijboerIT, I would not have thought Java necessary either, but there are some strange Java-related effects that come up here from time to time, so I thought it worth checking out (although I too would avoid it whenever possible). OpenJDK 7 will be fine as it is identical to Oracle 7 Java. Before you do install it, perhaps try using the --backtrace argument to see if this indicates more clearly what is occurring?

@NijboerIT @oweng: Would recommend 8 instead of 7 cuz says Java( SE) 7 is dead after April 2015 if no heavy reason says otherwise. I’ve always installed 8 after it was released March 2014 as told by the article. There’ll be a long road ahead for 8, until March 2017 at least, as told by the article.

Since you’re on Ubuntu, I always add Oracle Java (JDK) 8 Installer PPA (DISCONTINUED) : “WebUpd8” team as the PPA for Oracle Java.

Addendum: Sometimes a new package is released although Java wasn’t updated, those are internal changes regarding the package(s), which are revealed on that site. Always good idea to update anyway, some changes are mandatory.

okey installed openjdk-7-jre-headless still nothing.
i find it verry strange that i do not get any error no mather what i do.
could it possibly have something to do with fonts used in the document?

ps. i have tryed it on my normal computer with gui. and it works like a charm from commandline with headless. so it is probably something missing on the server.

@NijboerIT, “it is probably something missing on the server.” That would be my guess. I install everything (using sudo dpkg -i *.deb for the website version) but I know Ubuntu re-packages LO in a different manner i.e., Base is optional.

okey installed the complete libreoffice sudo apt-get install libreoffice still no sigar.

somehow solved it. absolutly no idea how… sorry!