odt document does not open

Rename the file and try to open the renamed version of your file. What does happen?

I renamed one of the copies of the document. Tried to open it, but the same behavior.
I did not have any problem with it until 2 days ago.
I do not remember to have done anything special that day.

I am also perplexed by what I read on the internet. That ~lock files appear when there are multiple users. As far as I know I am the only user of my computer.

Your files - are they stored on some cloud service like OneDrive, GoogleDrive or something like that? If not, I got absolutely no further idea what you are doing and what’s going on with your system.

I do have a copy of the document with problem in Dropbox and OneDrive each. They behave in the same way.
I had tried to open them when the copy on my desktop refused to open.

As I said before yesterday, after cliking “Continue in Safe Mode” it showed me a message: Your user profile has been exported as “libreoffice-profile.zip” I clicked “Open containing folder”, I tried to unzip winrar that appeared to the desktop. New icons came on the desktop which I collected to one folder.

But the fact that the file’s name is duplicated does it mean something? It shows, the name of the .odt file producing the error, OpenDocument Text, again the name of the .odt file producing the error, my name (author), date of modification, size of the document. Could this mean anything?
I mention it in case that could lead to something.

Other documents that opening normally do not have such anomaly in their name.

Please, I am in desperate need of having my problem solved. My file, as I mentioned in the other comment, shows duplicated name. I just feel that could indicate something. Myself being completely ignorant about computer problems cannot decipher it. Please, help me!