Paste unformatted text default option

Is there any way to set Paste Special (Unformatted text) as the default option when using Ctrl Shift V to paste in Calc, Writer etc? I have read that it is possible to create a macro and then assign a keyboard shortcut to it. I’m just wondering if there is a configuration option to toggle pasting formatted text to unformatted text as the default so that a paste special prompt isn’t displayed every time I paste some formatted text.

Alternatively, is there a way to set the import options to a default so that there isn’t a prompt for import options after pressing Ctrl V to paste?

None of these options work or are clearly explained. The actual solution is to select the cell you want to paste into, and then select the forumla bar at the top and CTRL + V to paste into the formula bar and NOT the cell.

There is no answer to the actual question, and still complaints that it doesn’t work in all instances: Changing a keyboard shortcut DOES NOT change the default behavior through the board, like in right click paste", nor can I see anyone needing, nor even wanting the default to be as is where it should be the opposite in the first place. If someone is gathering notes from several places in a document they are making, it should paste copied material to fit the rest of the document, not as it is in all of the different sources the texts come from. Really, who want’s a document with many different fonts, colors, sizes, fields unusable outside of their native origin? And it really makes no sense to import formatting, other than copying whole documents. I never want anything but my own formatting, in MY documents!

I have noticed for quite a few years, that Alex Kemp is way too quick to close topics, without putting much critical thought to the issue at hand. It doesn’t help anyone!

My favorite shortcut key for ‘Paste unformatted text’ is ‘Ctrl+U’,
assigned to that macro:

sub paste_unformatted
rem ----------------------------------------------------------------------
rem define variables
dim document   as object
dim dispatcher as object
rem ----------------------------------------------------------------------
rem get access to the document
document   = ThisComponent.CurrentController.Frame
dispatcher = createUnoService("com.sun.star.frame.DispatchHelper")

rem ----------------------------------------------------------------------
dim args1(0) as new com.sun.star.beans.PropertyValue
args1(0).Name = "SelectedFormat"
args1(0).Value = 1

dispatcher.executeDispatch(document, ".uno:ClipboardFormatItems", "", 0, args1())

end sub

You may create this macro as follows:

(1)
Record macro

Ctrl+Shift+V > U > Enter

Stop recording

(2)
[New window: LibreOffice Basic Macros]

Type ‘Macro name’ (e.g.): ‘paste_unformatted’ > Save

(3)
Tools > Customize > Keyboard >
Functions >
Category > LibreOffice Macros > user > Standard > Module1

Function > ‘paste_unformatted’

Shortcut keys > Ctrl+U > Modify > OK

Actually, it is quite easy. Just follow these steps (on the PC version 3.5, at least):

  1. Click on Tools
  2. Click on Customize…
  3. Click on the Keyboard tab at the top
  4. To the RIGHT of the Shortcut Keys box, click on LibreOffice
  5. Below the Shortcut Keys box, find the Functions box, then find and click on Edit
  6. In the next box, the Function box, find and click on Paste Unformatted Text
  7. In the Shortcut Keys box above, find and click once on Ctrl+V
  8. On the RIGHT, click the button titled Modify
  9. Optional: Click the Save… button and save your keyboard configuration so you can import in into another computer or if you reinstall LibreOffice
  10. Click the OK button at the bottom to finish.

That’s it! :slight_smile:

HTH,
Robert~

Thanks Robert! Worked like a charm. I’m using Ubuntu 12.04 LTS and LibreOffice 3.5.7.2.

Hi,

Just Signed In to say thank you Robert.

I am regularly copying and pasting text from SQL Server Management Studio Query Editor to Writer and was tired of waiting for the text color format to be retrieved when forgetting to type Shift with Ctrl+V.

This trick will save time and nerves.

a+,=)
-=Finiderire=-

Configuration :
LibreOffice v4.1.2.3 Portable
Windows 7 Service Pack 1 Professionnal

Thanks

In LibreOffice 4.3.0.4, the Paste Unformatted Text option is not present.

This option prevents pasting pictures.

@Genom: yes but once Ctrl+V is “paste unformatted text”, you can still use Ctrl+Shift+V (paste special) for pictures, or assign a different shortcut to the standard “paste”.

Thanks! It worked for me on Version: 5.4.7.2 (x64)

This should be the accepted answer. No need for macros!

"In Writer text documents, you can press Ctrl+Alt+Shift+V to paste the contents of the clipboard as unformatted text. "
http://help.libreoffice.org/Common/Pasting_Contents_in_Special_Formats

Doesn’t exactly deal with defaults, but perhaps useful in the meanwhile!

Actually, this is a “default” behaviour, because it shortcuts pressing CTRL+SHIFT+V and then selecting “Unformatted Text” to only one step.

Unfortunately, these options are not so configurable and you’ll need a macro to do what you wanting.

That should not be up to the users, but the developers: The defaults are reversed from what they should be, and there should at least be an option in the settings to set the default paste behavior! There are few and far apps in between that don’t let you costomize the keyboard shortcuts, and for mouse users, and those of us that just cannot memorize, let alone keep track of them no matter how hard we try!

I don’t know how to make a makro, but it should do the follwing (German UI…):
Press: ALT + B + H
Press: ENTER
Press: ENTER

i did same paste special, but it doesn’t work. the formula is still on active. ideally after paste special formula should not reflect.