Restart end-of-document footnotes per chapter

I’m sorry to ask to test something I can’t test myself ATM, but I’m not at my computer now. Isn’t it possible to use footnotes and place them at the end of the document?

But maybe I just don’t read the question carefully - it seems to tell that it already does just that.

Thank you, @ajlittoz for your quick reply.

No, I definitely don’t want endnotes at the end of each chapter/section, at least in the case of this book. Each chapter has upwards of 4-6 pages of notes. Readers who like the extra information provided in the notes won’t mind going to the end of the book to read them. But readers who don’t care much for such extra information will find 6 pages of notes an impediment to moving on to the next chapter. For such, the notes will become a barrier, “interrupting the flow” to the following chapter.

What’s really frustrating is that (as I mentioned in my initial posting) I have a long LOW document that works exactly as I want it to — footnotes (pretending to be endnotes) are assembled at the end of the ODM, with numbering restarting at the beginning of each chapter’s notes. I can’t duplicate that success in my current document either under LOW v. (my desktop) or here on my laptop (v., though both versions will open the successful document and leave it unchanged.

One problem might be that the “successful” ODM has an extra Text section after the sub-docs. I can’t add that section to the new document’s ODM. The ODM Navigator in v. will never give me an option to insert a Text section, because that option never appears in the Insert menu; there are only three options — Index / File / New Document. The ODM Navigator in does show “Text” as a fourth choice in that menu group, but it is always grayed out; it’s never available. Does anyone have any idea about why each of these conditions would exist?

Once again, thanks for any help.

@mikekaganski: Thanks for jumping in!

Yes, I’m using footnotes “as” endnotes, exactly as you suggest. It’s a strategy that worked just fine on another long ODM file from 4-5 years ago. See my new note to @ajlittoz .

To add a Text section, you must first select a sub-doc in the Navigator. Then Text is enabled and the text section is inserted before the selected sub-doc. Another procedure is to insert a new text section anywhere and to move it with the arrows in the Navigator toolbar.

I understand your rationale.

As you have noticed, you can’t restart footnote numbering as soon as you collect them at end of document. This is a failsafe precaution to avoid ambiguous numbers because you can’t add “decoration” paragraphs. Notes, whether foot- or end-, are internally generated from some cache. Decorations can only be “simulated” through the use of fake notes, e.g. you attach a “separator note” to a chapter heading with a “blank” number. Fortunately, you can apply any style you want to notes, allowing to embolden or center the separator note.

If you can prepare a 5-page max extract from your “good” file, i.e. 2 1-page chapters with one note in each, and attach it to the question, I’d be glad to analyse it.

@mikekaganski when footnotes are collected at end of document, numbering forcibly reverts to continuous numbering, even if it was per chapter before clicking on at end of document.

1 Like

I was going to tell you that what you said only works in theory. But I just discovered an apparent caveat to your statement. What you said DOES work — provided there are at least TWO subdocuments inserted in the ODM and the second (or subsequent subdoc, not the first) is chosen. With only one subdoc, there’s no non-Text area in which to stick the new Text area. But with two or more subdocs, it works.

So far, so good. No progress elsewhere, but this at least is a step forward.

I’m on deadline for another project this morning, but I will try to create the pared-down version of the “good” file and get it to you before day’s end here in Virginia. Thanks for the offer, @ajlittoz !

@ajlittoz, one more question, please:

When putting the “trailing” Text areas into the ODM, is there some way to designate and tell LOW, “Put the collected footnotes here”? I can insert various indices, etc.; but I can’t find a way to designate the location of the Footnote section. Maybe part of my problem is that the footnotes don’t have a landing area…

Footnote location is configured in Tools>Footnotes & Endnotes in most generic terms (page footer, end of chapter, end of document). This is a “logical” location. You can’t specify a “physical” location: The sequence of text and sub-document sections is a continuous virtual stream. Writer uses the “logical” location and maps it over the “physical” stream, except perhaps for end of document where it might create a last text section in the master (I don’t remember though I made a test this morning before answering).

The issue is not in footnote landing area. They’ll have one anyway. I think it is in the generation process. While the document is scanned for layout, note contents is collected in some internal cache until the time it is needed (bottom of page, end of chapter or end of document). Then it is flushed out. The note number is computed when the note is met. The solution boils down to enabling some restart when conditions are met. Presently, the configuration doesn’t allow it. This is why I’m curious to see how your “good” document is encoded. It is possible that some change removed the possibility from the UI while the ODF specification allows it.

This has been my fear for the few weeks I’ve been wrestling with this. Which brings up a related question — Does an ODF (or ODM) file contain any memory of which version of LOW created it initially? If so, the “good” file might yield this information; and, if that’s the case, perhaps I could revert to that version for the duration of the project…

looking at my own files, it looks like there is an XML element <meta:generator> which reports the LO version used probably at time of last save. – Confirmed – If you save your original file as .fodt (for ease of reading the XML preamble), you’ll get your current version identification.

Extracting this information without modifying the file is a bit more tricky. An .odt is nothing more than a ZIP archive. Make a copy as a safety measure. Extract it in some convenient location. Open meta.xml in a text editor. Search for meta:generator. You’ll read the latest LO version which touched the file.

Responding this again:

  1. Would it be okay to include the ODM and a full two chapters of ODT? They’re short. In fact, the book from which they are taken is only a 6-in by 9-in format document. (I can zip these three files together to make them even smaller.) BTW, as you will see, this experiment was successful. It still re-numbers the footnotes at the end. I was afraid v. would strip away whatever “magic” was allowing this file to perform normally.
  2. Is there an upload option on the forum here? Or should I send it to you via PM?

To upload, either edit your question or add a comment. The tool has an icon looking like a mail basket with an up-arrow. I think you can attach the 3 files without zipping them.

@ajlittoz — FWIW, because I iterate through so many drafts while I write (why not, since storage is cheap?), I always add the current (and often the time) to a file when I save it.

That being the case, I wondered if it would be of any import that the ODM of the “working” footnote manuscript is dated “2017-02-06,” i.e., 6 Feb 2017.

I don’t think the date itself is relevant. The important factor is the LO version used to save it on this date.

Yes, and that’s what I don’t know how to determine. You said that looking at the XML reveals the last LOW version to touch the file. I was hoping the originating version info was imbedded.

"New users can only upload 2 files," and I was trying to upload the ODM and two ODTs. ZIPs don’t seem to be on the upload utilitiy’s radar either. If I posted these on a personal storage account (say, GDrive or Dropbox) could I PM the link to you?

Create a ZIP file.
Change the extent from ZIP to ODT.
So you can upload the file here.
Anyone who downloads your file must then change ODT back to ZIP.

Thanks, @Hrbrgr. It’s good to get to know one of the tricks of the forum.

1 Like

Footnotes-at-End-Test-zipped.odt (134.2 KB)
@ajlittoz, here you are. I hope you can ferret out the secret.

I apologize for the delay. When I pressed the “send” button yesterday, the ever-vigilant forum-bot kindly informed me that I had sent the maximum number of messages allowed to new users, and that I would have to wait 13 hours before sending my next missive. Oh, well — patience is a virtue to be mastered…

First result: the “chapters” were written with LO
I’m trying to discover the setting to reset footnote number. Perhaps, there was no parameter forcing in this release when you switch from notes at page bottom to at end of document.
There are also “many” formatting “rrors”, the most serious of which is using Default Paragraph Style for real text. This style is the ancestor of all others and everything you set there forces you to override in other styles when that setting conflict with your graphical charter.

It was very difficult but I found something. I think a change between and now ( on my computer) is to be blamed for the difference. From experiment, when you configure your footnotes for “end of document”, numbering is reset to “per document”.
In the underlying XML, if I force the setting for “chapter”, Writer behaves as you were used to. Consequently, code for it is still there. I suppose this parameter forcing was introduced to remove a case of numbering ambiguity for the common case where notes at end have no chapter separator.

Bug report is tdf#150207

The temporary fix for you is not obvious and may be dangerous for your documents. I’ll give a procedure in an answer.

Analysis your “chapters” shows that your formatting is rather “elementary” and can greatly be improved.

  • don’t use Default Paragraph Style for your text; Text Body is the standard style for this
  • you never use character styles; instead you apply manual formatting for bold, italics and other variations
  • don’t use empty paragraphs for vertical spacing; instead customise paragraph styles; since you don’t pay special attention to the style of these empty paragraphs, some of them are Heading n and end up in the TOC forcing you to manually edit the TOC to erase spurious entries
  • you number your chapters manually instead of relying on Tools>Chapter Numbering; in case you shuffle your chapters, you’ll have to renumber manually
    If this is motivated by your need for unnumbered chapters, you can always have unnumbered headings by pressing Bksp once at the very beginning of a heading. This removes the number.
  • don’t use manual page breaks for forcing page parity (starting a chapter on a right page); you’ll have to check this manually whenever you edit your book; instead play with page style properties and their automatic sequencing
  • instead of inserting chapter “separator” manually among the end notes (which is not reliable in case of edits and isn’t possible with real endnotes), attach an unnumbered footnote to a chapter heading; the corresponding note will be inserted at the right location and you can style it with any style you like. With fields, you can also echo the chapter heading automatically, so that you don’t need to type it again (and when you modify it, the field updates)
  • you’re not consistent in your end-of-sentence horizontal spacing
    Sometimes you use two spaces after a full stop. This translates to a <text:s/> element in the XML (I don’t know what it does but I’d recommend using a single space and letting Writer do the job; double spaces disturbs its job)


Note that for a new document, this is set to Per document, and there’s no way to change it to anything else, because there’s only one element in this list.

The Per document seems to imply exactly what is wanted, but works differently. Possibly needs investigation what changed this; I suspect one of Caolan’s welding commits.