Show page border in LibreOffice Writer documents

I have just updated to the latest iteration of LibreOffice, and I cannot work out how to show a page border round a document. When I open an A4 document (or even a blank page) I want to be able to see the page defined as if it were a piece of paper, and any text placed within it. This was the default position in the version of LibreOffice I was using before (sorry - can’t remember which version), and it is very annoying to see text appearing in the middle of a large white void. Any ideas would be gratefully received.

menu:View>Text boundaries

As is, it is absolutely impossible to answer your question. If you don’t remember the previous version, you could at least mention the present one (“latest version” means absolutely nothing because upgrade pace proceeds at different speed on different platforms and even across distribution on same platform). Mention your OS too.

If you can’t better describe your situation, take a screenshot of the full screen, not a single window or area within this window.

If you’re under Windiws, have you cold-rebooted your machine? This step seems necessary under W$.

You may have switched to View>Web. Revert to View>Normal. Enable the various View>xxx Boundaries. View>Formatting Marks also helps.

Here are the details of the LibreOffice version I am using, as it appears on my opening page:-

Version: (X86_64) / LibreOffice Community
Build ID: 60(Build:1)
CPU threads: 2; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-GB (en_GB.UTF-8); UI: en-GB
Ubuntu package version: 4:7.6.2~rc1-0ubuntu0.22.04.1~lo1
Calc: threaded

I am using Linux Mint 21 Vanessa, to which I upgraded yesterday, which is why I had to reload LibreOffice. I would send you a screenshot of what a page in LibreOffice Writer looks like for me, but I can’t work out how to do it, as the file size is too large. I am in Normal View, and have already tried the Boundaries/Formatting Marks options that you mention.

I hope that this helps a bit - thanks.

Does not help much unfortunately. Is your zoom factor out of reasonable range? Look at the right side of the status bar:

Zoom factor is central, as in your example, thanks. I’ll try to work out how to send a screenshot of a page.

Reduce the window size before the screenshot is taken.

Cannot spend any time on this until tomorrow, but will see what I can do. Thanks

Here are two screenshots of the same document. The one in portrait mode is from my tablet, and shows borders defining the whole A4 document. This is what I want (not borders defining the text.
The one in landscape mode is from my desktop, with no borders at all in the document. This is what I want to rectify, so that it resembles the document as it appears on the tablet.
I know that I can see a document with page margins in Print Preview, but I want to be able to see those margins all the time.
Thanks again for any assistance.

Your second screenshot (from desktop) also shows the margins. But possibly the contrast is too low for your eyesight?

See also: tdf#156448 - there was/is a problem of missing shadow below the page, which could add to the poor separation between the margins and the background.

See: OptionsLibreOfficeApplication Colors, Document background and Application background.

In the bottom right of your screenshot there is a slider with adjacent label showing a zoom level of 68%. Perhaps increasing the zoom level to say 100% may make a difference; use the slider, or View | Zoom.

Thank you. Going into the Options menu (which I haven’t used for so long that I had forgotten about it) gave me what I wanted. I still don’t understand why the upgrade of LibreOffice retained almost every other parameter that I had previously set (font size and colour; default spacing and alignments etc) but lost the background shading. A pity that LibreOffice Help is so impenetrably Byzantine in its convolutions that this information, if it is there at all, must be buried in the dark recesses…

Thanks. This was suggested before by ajlittoz, but didn’t help. mikekaganski’s suggestion of going into the Options menu did bear fruit, however, as you can see from my reply to him.

Related question:

1 Like

Another related comment where I link to a Wikipedia page for screen adjustment: How to make Writer page adhere to system/LO theme? - #5 by ajlittoz. The adjustments are done on the monitor, not in any control center module. Thus, the adjustments are OS-agnostic (valid for all of them).

1 Like