[SOLVED] [Calc][Linux] Copy / Paste non-continous selection

It’s a very specific question occurring only on Lubuntu 19.10.1 (not Lubuntu 18 or windows) but still a calc question.
It’s probably just a configuration thing coming from the preinstall LO available on the distro. (same pb on LO or but strangely my uninstall of 6.3 preinstall let personal config available for 6.4 download from LO ).

Here we go :
when I select A1 and A3 (without A2) and copy/Paste to B1, only the content of A1 is paste on B1 exactly like if i have use the “paste Unformated text” or “paste special”. (on other systems it paste A1 on B1 and A3 on B2).
If I try to paste outside LO only A1 is paste but it’s the same on every system.

Any idea to solve this? Thanks

PS: Not a question just something to know
If you use paste unformated text, depending on the LO version, you will have different result depending on the car set used UTF8, UTF16, windows-1252… so be aware.

Did you already try with a reset (virgin) user profile?
See LibreOffice user profile - The Document Foundation Wiki and be sure to backup your existing profile.

Doesn’t happen for me (Wayland on Fedora), result is pasted to B1:B2. Sounds like another (or the same) X11 Mutter composer clipboard “manager” related bug in that it doesn’t offer the Calc internal clipboard format to Calc itself. See also Copy/Paste clipboard issues LibreOffice Calc

on erAck link chat

I have install wl-clipboard (available on Muon pack installer) and the problem is solved.

(so not really a LO question in the end…)

Thanks everyone