(Solved) LibreCalc will only print 129 0f 200 rows

I’m using linux mint 20 with libreoffice v7.03 and I have a xlsx file that has 200 rows but it will only printout 129 of 200.
Can anyone help me to print out my complete xlsx file.



@kato181: suggestion for improvement❗ new formula in I2: =SUM(B2:G2,-H2,I1)

Or with a formula like =SUM($B$2:$G2)-SUM($H$2:$H2) you can add or delete rows without loos carried values.

Here are some things to check/try.

  1. Doublcheck if your printing range and areas are correct
  2. Try printing in safe-mode to check if it is an error with your profile?
  3. Try printing to PDF ans see if the issue is the same
  4. Convert the XLSX to a native ODF and check if the issue remains
  5. Upload the file here an let somebody else cross check if he issue exists.
  6. Remove any custom printing ranges via (Format > “Print Ranges …” > Clear)

Just some ideas. Later.
Hope they/it helps.

I have tried all your suggestions, but to no avail.
I cannot see where I can upload the file as you suggested.

Edit your original question,
and select the attachment icon.

I think it should usable at your current karma level

I looked at your file and it looks like you somehow set a custom print range, to fix the problem, you just have to remove it. Just do:

Format > “Print Ranges …” > Clear

After that you should be able to Print and “Print Preview” as you would expect.

Sorry for the late reply.

Hope that it still helps.

@kato181 Now that printing has been addressed you should have a look at your spreadsheet formulas. To avoid problems with different formulas you should be consistent. In your example sometimes you subtract the cell in column H, but when there is nothing there you don’t subtract, this is dangerous in a spreadsheet as you can end up with an incorrect result if you forget to include the subtraction (you haven’t as yet). I suggest you enter in cell I3 the formula =I2+SUM(B3:G3)-H3 and copy it down: copy cell, press Ctrl+Shift+downarrow and paste.

Thanks mate that did indeed fix my printing problem, but I don’t know how I fiddled with the Print Range.
I also inserted the formula.
Thanks again everyone for your assistance.

@kato181, please be so kind and mark the answer as solved, if your question has been answered.

Take a look on the page format, [sheet] tab, scale options.

Tried that, but still the same. If you load my xlsx file that i attached and try to print it will only show upto 24/03/2020

i can’t see the file, please edit your question and add it?

I have attached the file to the original post. It is…

Sorry I can’t see it in the original post.

That’s weird I have uploaded it twice. I’ll do it again. Here is the link that it gave me after I uploaded the file.
Find attached the file.(/upfiles/16052451452599032.xlsx)