some keyboards shortcuts not working

following don’t seem to work.

thesaurus- ctrl F7 [writer]

options- alt F12 [writer, calc, draw]

insert table- ctrl F12 [writer]

toggle formatting marks- ctrl F10 [writer]

Version: 7.0.4.2
Build ID: dcf040e67528d9187c66b2379df5ea4407429775
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-IN (en_IN); UI: en-US
Calc: threaded

update: tried with live usb of Linuxmint 19.3 xfce with preinstalled LO [didn’t note version], issue still present.

Most probably, the shortcuts are intercepted by your window manager/desktop environment.

I use Linuxmint 19.3 xfce, but not configured those shortcuts for something else. As far as I remember, never ever.

How did you install LibreOffice? Did you use the same method for the dictionary and thesaurus?
Are your settings for USER INTERFACE, LOCALE and LANGUAGE the same. Remember English (UK), for example is NOT the same as English(USA).

How did you install LibreOffice? : tar of deb from site.

Did you use the same method for the dictionary and thesaurus? : do you mean a similar shortcut for some dictionary extension? Then no.

Are your settings for USER INTERFACE, LOCALE and LANGUAGE the same? : No, LO interface is (USA) but locale is (India), default doc language [if that’s what you meant by 3rd] is again (India)

I tried on another laptop too having almost clean and updated Linuxmint 19.3 xfce with almost untouched LO from the repo [unlike mentioned above]. There too not working, though the thesaurus option is inactive I don’t know why.

indeed this maybe xfce related, just discovered that alt+f12 is for toggling a window’s ‘always on top’ option. Rest combinations- no idea yet.

Have you tried having all the settings for the same default language? Englist (USA) for USER INTERFACE
LOCALE and DEFAULT DOC LANGUAGE. This function will be there in the default system installation.

tried with same default language in above mentioned options, no success. Also tried by changing system language and restarting in safe mode.

reported at tdf #139726

On my Linux Mint system you must first locate the cursor on the document so that LibreOffice knows which document and where to locate your request. So for example Ctrl-N (new writer document) needs Cursor select before Ctrl-F7 will activate. Hope that works for you also…Peter

cursor located, also tried by selecting text, no success.

I tried on another laptop too having almost clean and updated Linuxmint 19.3 xfce with almost untouched LO from the repo [unlike mentioned above]. Maybe this is related to xfce, did you test on Mint xfce?

They are all default shortcuts in xfce. Remove them from settings > Window manager > Keyboard tab so that they become active in other applications.