Table changed multiple cells to 0

Which version of LibreOffice do you use, on which operating system? (x64) on a Windows 10 computer

The pasted table at does not give any clues as far as I can tell. Your original file may still contain “residue” from the deletion/mangling of content. If you want people to take a look at that, keep an untouched (or touched as little as possible) copy. In another copy, delete everything except the offending tables. Do editing inside the tables only if you must, to remove confidential info. Editing objects will sometimes completely rebuild object structure, which may remove the evidence we are looking for.

Before that, perhaps investigate a bit yourself:

If you have enabled “version saving” for the file, there may be previous states of the document saved. See File - Versions

The file system may also contain salvageable data. Open the folder in your file manager (Windows explorer), right click the file and select Properties, then look under the Previous versions tab if you have that in the properties dialog.

Thanks for your help keme. I’ve taken a look at everything I can think of (and there aren’t any previous versions). After replacing all the lost things all day Friday, I’ve found that it happened again to a separate subset of tables and I’ve lost even more. At this point I don’t have the time or patience to find the reason and stop this from happening a third time, so I’m just going to bite the paywall bullet and switch to a program that won’t have this happen. Thanks again!

1.Open the file with winrar and extract the content.xml file.

2 Open it with notepad++.

3 Replace all office:value-type=“float” office:value=“0” with office:value-type=“string”.

4 Save the file.

5 With winrar, add the content.xml file to the original LibreOffice file.

6 Done. And tedious.

Similar answer in /es site. Writer reemplazo el texto de una tabla con "0". Original file (now .odt) was a .doc(x).

Life saver after loosing my data for the second time. Thanks.

Saved me a lot of hours of retyping, too. I’ll point out that the replacement above is office:value-type=“float” for office:value-type=“string”, while office:value=“0” just gets deleted, which should be obvious from SergioB’s answer, but I still needed 3 attempts to grasp.

Thank you.

Hello, same problem here in Writer. I’m using Libreoffice on Debian Linux (Buster).

image description

Please file a bug with attached sample ODT (that opens OK in an older LibreOffice, and with 0s in newer), which would enable to reproduce and fix.

Thanks for the new information. As it is not an answer to the question, please, repost it as a comment. To do that, hover on “more” (just above these comments), and press “repost as comment under question”. Thanks.

Just like in Calc, you can format your cells (Table>Number Format)

Those in the first column have attribute “Text”. Some in the rest of the table have attribute “Number” with format string “0”, instead of “General”, accounting only for numeric values. A text will display 0. Unfortunately, original text is lost and can’t be restored.

Unfortunately, original text is lost and can’t be restored


  1. Open the file with winrar and extract the content.xml file.
  2. Open it with notepad++.
  3. Replace all office:value-type=“float” office:value=“0” with office:value-type=“string”
  4. Save the file.
  5. With winrar, add the content.xml file to the original LibreOffice file.
  6. Done. And tedious.

Hi, I also have the same problem.
I found a temporal solution to recover the data! → If you are in Windows open the file with Wordpad.

Again: please, PLEASE, file a bug with a sample problematic document! And leave a note here with the bug #. So far, neither OP, nor @iak did, so no one could be able to do anything about it.

OK, here is the bug number: Bug 131025
I atached the file there.

Just going to say that I solved this for me. I save the file as Microsoft formats and tick the Dont remind me again button and I dont get this issue. Ad I can open in word if any of my friends want the document…

It might not be the answer you wanted but it works.

and if the people are going to sugest that this is your fault for not lodging faults and giving N’degree details then Im sorry but their custoer service skills sucks. and they dont deserver our support.

Customer Service 101:
Dont blame the end user for a programming error…

The Ask site is not, I repeat, not the customer service department of LibreOffice. It’s a place where users ask for help and other users help them, when they can. Those users helping other users aren’t paid for that, and more often than not, the OP doesn’t even bother to come back and say “thank you for your time and effort”. I know @Keme as a very helpful and very polite person, his comment is spot on. If you want help, you need to state what your problem is, and in some cases you have to be very specific indeed. If you don’t like that, go somewhere else.

We don’t “blame the user” for developer errors. We may suggest the possibility that the user made a mistake. The purpose is to cover all bases, not to place the blame. Most users will accept that as a possibility, but some will take offense where none is intended. This time the OP investigated based on the comments given, and did not arrive at a solution. The answer from SergioB was later accepted as a solution, so it must be the one.

@Darkeen: I submit that your suggested solution, to save in Microsoft format and disable warnings, is the wrong one unless you are using Microsoft software. If someone follows your advice (perhaps not so likely) and it causes data loss (also not likely but very much a possibility), you are the one to blame.

There you have it, sometimes we DO place the blame. Satisfied?

Small update to the published solution: instead of winrar save as a flat xml odf file in Libre Office and then use Notepad++ (or other text editor) to find and replace: value-type=“float”* for office:value-type=“string”. I did a replace all with no problems but this may depend on your file.