Table of Contents single column width

I want to change the width of my single column TOC. Width options are grayed out in -Right click > Edit Index/Table > Columns tab.

Please help.

(edit: activated screenshot)

If you are using a single column, then the way to change the width is to adjust the margins of the page, as that is what the column boundaries are in this case. First, you will need to define a page style for your ToC pages e.g., Narrow_ToC

screenshot showing icon

  1. Once your page style is defined, insert a manual page break prior to where your ToC is required and select your Narrow_ToC page style.
  2. Place a couple of carriage returns on this page.
  3. Insert your ToC at the beginning of the page (above the carriage returns).
  4. Go to the last inserted carriage return (below your ToC) and insert another manual page break, this time selecting your usual (e.g., Default Style) page style.

“Define a page style for your ToC pages e.g., Narrow_ToC.”

I have no idea how to do that and searching on it only tells me how to define pages for an entire doc.

I will update my answer to include a link to the help page and a screenshot showing the page style icon.

Thanks for all your help. I can’t change page style for only one page. Manual break or not, changing the page style for any one page changes them all. So I guess the question is, how to isolate one page for style change?

You need to use a manual page break with an associated page style. I provide step-by-step instructions on creating and changing page styles in this answer.

My TOC is less than a half page tall, and the page contains regular content. So the page needs to have the same style as the other pages.

Is there no way to change the width of a TOC without breaking the page layout?

@PeterLairo1, there are only a few ugly hacks available to do this: (a) manually create the ToC; (b) as suggested below by @WoodGrainPro pseudo-manually create the ToC; (c) style the ToC as two columns and insert a column break to push all the content to one column. A ToC is almost invariably presented on a page by itself, so having other content on the same page is irregular.

I found a solution, kind of.

  1. Create TOC, make it editable and make any changes you want to it.
  2. Create a one column table separate from the TOC, but on the same page. Adust width, border, alignment…
  3. Highlight the TOC and drag it into the table.

After it’s in the table, you won’t be able to turn off the protection mode/right clicking doesn’t give you the “Edit Index/Table” option.

Sorry if this answer is kinda lame but I’m actually trying to PRODUCE something and I just spent 3 hours on this issue. :^(

Edit: Doing it this way means you cannot update the TOC, as the right click menu presented will be for tables, not TOC. My solution at this point is to not create a TOC until the document is 100% ready to ship, then follow steps above.

If someone has a better way to change TOC width, please post. Thanks.

Avoid using tables or frames or other types of containers. The container in a single-column instance is the page. Refer my answer for greater detail.

Have you tried putting your TOC in a single cell table or frame with no borders? I mean first creating the table and then clicking inside it and choosing Insert → … → Table of Contents. Then you should be able to resize it to your will. Alternatively just change the margins of the page it is on.

Yes: this works perfectly: I inserted a frame, then inserted the ToC inside the frame. Could then style, position etc. the frame as I wished. ToC content still correctly updated with no problems and without interfering with the frame styling. I know this is counter to oweng’s specific advice not to embed ToC inside a “table or frame or other type of container”: so it may yet cause problems later. But prima facia, it seems fine.