The database is already in use by another process: lockFile

My databases were working fine yesterday, and now they are locked, or permission denied.

Earlier today, I installed a round of updates to my Ubuntu machine, and rebooted. Now when I want to enter data to my weather database, I get this message:

The connection to the data source “LeedsWeather” could not be established.
The database is already in use by another process:lockFile:
= /home/rob/Documents/base/LeedsWeather.odb.lck,
exists=false, locked=false, valid=false,] method:openRAF
(Permission denied)

I hope this can be fixed easily.

I have the same problem
Libreoffice Versione:
Build ID: 1:5.4.5-0 ubuntu0.17.10.1
GNOME 3.26.2

The same problem.
Libreoffice Version: 1:5.4.5-0ubuntu0.17.10.1
Gnome Version: 3.22+5ubuntu2

Same problem here. Ubuntu 16.04, Gnome 3.18.5. Libreoffice Build ID 1:5.4.5-0ubuntu0.16.04.1~lo1.


Since this is the second post today (first errantly as an answer) and third this week, I moved to my Ubuntu system.

It is Ubuntu 17.10 Mate. Here I have installed LO (TDF version):

Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group

Opened one of my existing odb file without problem.

Next updated Ubuntu with all outstanding updates including Kernel. This required a system re-boot to complete the updates.

With updates and re-boot complete, used same odb opened previously. No problems.

Created NEW base odb without problem. Added a table & form without problem.

Since all three questions (this and two here) all seem to have the same problem, it may be the difference is where the LO version is coming from. So it may be a Ubuntu distro version or a PPA version problem with conflicts in updated OS.

From my test, LO doesn’t seem to be the problem. This probably requires contact with Ubuntu or PPA.

Yes it is Ubuntu 17.10, and I’ve just found that I can’t click on tables without the error message popping up.

I don’t want to create a new base obd if I can’t add the tables and queries, as I want to use my existing odb of over 6000 records.

All in all your reply does not answer my problem, but thanks anyway

@Avvy65 You haven’t mentioned where your version of LO came from. My answer states the test using the TDF version shows no such problem whether using an older established odb OR creating a new odb. The answer also states if using a distro or PPA version, there is a probable problem with their version. Therefore you must contact them for resolution. No, it doesn’t correct your problem but rather may provide where the actual problem resides.

Yesterday I’ve answered someone on IRC who couldn’t open documents on a NFS (?) share (reportedly due to permission problems) after upgrading to Ubuntu 17.10, using LO from the distro. The person then had tried a containered version of LO, and it worked fine. So yes, this seems to be the problem of Ubuntu packaging.

@mikekaganski Thank you for the comment. I was beginning to think my time testing was a waste.

Ratslinger I got my version of LO from the software button or icon, so wherever that got it from. All except dBase was installed with Ubuntu, and then I used the software thingy to install dBase. Yes maybe it was installed from a ppa, and I will contact Ubuntu about it.

@Avvy65 It would really help if you learned some semblance of terminology. From what you seem to say in your comment, you have a distro (distribution) version. Ubuntu would be the place to go to. Don’t think ‘software thingy’ is a term you should be using when looking for answers.

Solved by adding PPA Libreoffice

sudo add-apt-repository ppa:libreoffice/ppa

and then upgrading to version 6

Yes. If you look in comments under my answer, this was stated as a distro problem. PPA & TDF should be OK.