When I create a new document with the Windows right click menu the document does not have the formatting of the default document.

Using File Manager in Windows to create a new LibreOffice writer document the document does not pick up the default template formatting.

This used to work with OpenOffice.

If you use the right click context menu to create a new document then the default template is not used. The template used is in Program Files/LibreOffice(n)/share/template/shellnew/soffice.odt.

Thank you! This works! Although replace “Program Files” with whatever path you installed LibreOffice.

Thanks again! I’ve been trying to fix this problem for ages. Your solution works! Maybe in a future version, when the default template is changed, the soffice.odt file could be updated too. Either that or could the soffice.odt file be used for all new writer documents, however created?

so how do I fix that?
I tried just to open the soffice.odt, change the paragraph styles, change the font, then save it in that folder.

But still if I make a new document by right click, new document, then open it, it has a default “preformatted text” format, not any of the changes that I specify.

Please tell me how to make a new document that uses my default template.

Did you restart LibreOffice?

The template path is defined in registry, under HKEY_CLASSES_ROOT\.odt\LibreOffice.WriterDocument.1\ShellNew. Typically, a value of C:\Program Files\LibreOffice\share\template\shellnew\soffice.odt is set there for FileName. You may check, and if different, either change to your preference, or modify the correct template.

And please, don’t ask questions using Answers. Put whatever necessary to your own question.

Sorry - new to this type of forum.
thanks - I see that tdf#120822 explained the issue, as you pointed out in another post, for anyone else that may need it.

thank you!

The tdf#120822 is not the same bug.