When I go to tools/highlite code i get a python script error errorr

A Scripting Framework error occurred while running the Python script vnd.sun.star.script:codehighlighter.oxt|python|highlight.py$create_dialog?language=Python&location=user:uno_packages.

Message: <class ‘ImportError’>: No module named ‘pygments’ (or ‘pygments.styles’ is unknown)
File “/Applications/LibreOffice.app/Contents/Resources/pythonscript.py”, line 1063, in getScript
mod = self.provCtx.getModuleByUrl( fileUri )
File “/Applications/LibreOffice.app/Contents/Resources/pythonscript.py”, line 500, in getModuleByUrl
exec(code, entry.module.dict)
File “/Users/merlinuk/Library/Application Support/LibreOffice/4/user/uno_packages/cache/uno_packages/lu199655jx00d.tmp_/codehighlighter.oxt/python/highlight.py”, line 21, in
from pygments import styles
File “/Applications/LibreOffice.app/Contents/Resources/uno.py”, line 434, in _uno_import
raise uno_import_exc
File “/Applications/LibreOffice.app/Contents/Resources/uno.py”, line 356, in _uno_import
return _builtin_import(name, *optargs, **kwargs)

Seems you are talking about an extension - Code Highlighter. Hence you should turn to the developer of the extension.