Why does Libre Office suddenly not recognize java?

As of today, 18 Dec 2017, Libre Office will not work at all. None of it. All I can say is that I continue to get an error that says “LibreOffice requires a Java runtime environment (JRE) to perform this task. Please install a JRE and restart LibreOffice.” and nothing will load. Nothing will initiate.

And yes, before you ask, I have the current java complex loaded and it works fine with everything else.

Installed is Java jre1.8.0_152, 64-bit, with all updates, and 64-bit Libre Office.

Also, I do have the most current Firefox installed and I know that java won’t really work with it and why.




You have given much information but which OS are you using? This is important. It matters not what everything else does with Java. LO needs Java depending on OS & LO bit-wise.

I am using Windows 10 Pro, 64-bit, Version 1709 (build 16299.125). Hope that helps! Thanks!

You need to have 64-bit JRE installed. You can get this from Oracle. Get this from link in my answer posted here.

Uummm… If you’ll take a peek above, I have already stated that I have java 64-bit and LO 64-bit installed. I have even uninstalled both and re-installed both, so I’m still stuck.

One of the installation pieces is the LO options as mentioned in the linked post. Here is the direct link to that post - click here. Are these set correctly?

Thank you! It finally worked, though I have no idea why. I have uninstalled and re-installed and cleaned and recleaned till I was blue in the face. We got it to work with your help, though. Thanks again!

Tools - options- libreoffice - advanced check use java runtime environment and check the jre that shows up. The jre that shows up will take a minute to appear. Wait for it.

Sorry, that has not worked the times I waited, either. The check-box to “use a java runtime…” is checked Also, it refuses to “add” java - just keeps saying that the folder where java is does not contain java. Thanks, though!

Only very few portions of LibreOffice need Java at all, unless you have some extension installed that needs Java for about everything you do. You can try to start LibreOffice from the command line with soffice --safe-mode that starts with a temporary configuration. If that works then rename your user profile as lined out in Wiki UserProfile.

Sorry, not even in safe mode. Not even with re-naming. The wiki says that I possibly have corrupted files - don’t know how that can happen with a totally clean re-install, but whatever…

IMHO, LibreOffice works fine without Java. I just downloaded LibreOffice 5.4.6, a “Still” version. Some features might or might not work without Java. However, LibreOffice Writer Document and LibreOffice Calc Spreadsheet work without Java.

Can you go to Tools > Options > Advanced and then uncheck the Java option?