Why does LibreOffice calc copy text and paste pictures randomly?

Recently upgraded to Version: when moving to Ubuntu 19.04

Like the version. But I’m having trouble using copy paste in Calc. It appears I’ve found a bug in the wild.

When I copy cells using CTRL+C and paste with CTRL+V:
Most of the time the first time I copy and paste information it gets pasted as a picture of the cells I copied

After undo-ing everything, I copy again following exactly the same selection and copy method.
But this time the contents of the cells are copied and pasted.

I’ve tried using the right-click menu as an alternative with the same results.

Please advise if there is a less frustrating workaround for this bug.

Why does LibreOffice calc copy text and paste pictures randomly

This statement is contradictory in itself. If Calc copies text, then nothing can paste a picture (an images). You just assume to copy text but you don’t. That’s why there is a Paste Special (CTRL+SHIFT+V) functionality. In addition you need to take into account that there might be a clipboard manager in place and then LibreOffice got no control how this piece of software handles all these copied entities.

@anon73440385 I don’t make the software I just use it. And I’ve been using spreadsheets for years.
“This statement is contradictory in itself.” – Exactly the software works contrary to its design - hence I called it a bug.

I’ve added more detail below to make it clear what steps I follow…

My task involves moving several rows of information from the main sheet to another sheet.

Here are the exact steps I followed:

  1. I have imported CSV data and saved it as ODS format.
  2. I select all the cells in a row with the mouse
  3. I press CTRL + c (and have also tried right click + copy | and also tried cutting which produces the same results when I paste)
    4.I want to move the row to another sheet
    5.I create the sheet for the first row I want to paste
  4. I press CTRL + v (and I’ve also tried using right click + paste)
  5. Now a picture of the row I copied is inserted
  6. I grunt and undo the paste
  7. Then I follow steps 2,3,6 exactly the same way but this time text gets copied as expected.

I don’t make it either - I just use it and I never faced what you describe in Copy&Paste from one Calc sheet to another Calc sheet (same format !) and that’s why I’d point to Ubuntu’s clipboard manager as a first source of the problem (I may be complete wrong - thus your detailed description is important to problem analysis). In that sense it is not yet clear which part of the process is causing the problem and it’s just too early to state LibreOffice is causing a / the bug and works contrary to its design. And to make it clear: CTRL+C doesn’t copy text but cells including all of its formatting and properties. It’s a misconception, if you assume the design would be CTRL+C to copy text only.

Which desktop manager are you using (GNOME, Mate, Xfce, KDE …)?

This is a bug in the recent Mutter clipboard manager in Ubuntu 19.04, see comments in Copy/Paste clipboard issues LibreOffice Calc for details.

Thanks I’m glad the bug has been identified.