Why does LibrOffice starts so slow?

After not finding a solution in previous answers, I hope for a new answer that would solve the problem …
I’m running vs. 6.3.3 in a 64 bit environment under Windows 10 Pro.
No matter whether I start Writer directly of by clicking an .odt document, I have to wait around 65 seconds before I the program is started so far that I can start working.
What can I do to get it much faster started?
(Comparing with OO that is ready starting after ca 10 seconds).

Hello,

your user profile could be the cause of this - thus test your user profile causing issue:

Case 1: LibreOffice can still be started

  • Start in Safe Mode using Help -> Restart in Safe Mode and confirm the restart using button: Restart
  • Archive your profile expanding Advanced (click on the word Advanced right above Help button) and click Archive User Profile button
  • Click button Continue in Safe Mode

If that runs much faster - then a corrupt user profile may be the cause and you should reset the user profile using almost the same procedure but instead of Continue in Safe Mode you perform:

  • Select option Reset to factory settiings
  • Activate [x] Reset entire user profile
  • Click button Apply Changes and Restart

Do you have same antivir running?

Thanks a lot Opaque!
That did it.
Never would have thought for a solution in that direction.

Just for the records (according to last comment of OP):

Your user profile could be the cause of this - thus test your user profile:

  • Start in Safe Mode using Help -> Restart in Safe Mode and confirm the restart using button: Restart
  • Archive your profile expanding Advanced (click on the word Advanced right above Help button) and click Archive User Profile button
  • Click button Continue in Safe Mode

If that runs much faster - then a corrupt user profile may be the cause and you should reset the user profile using the following procedure:

  • Start in Safe Mode using Help -> Restart in Safe Mode and confirm the restart using button: Restart
  • Archive your profile expanding Advanced (click on the word Advanced right above Help button) and click Archive User Profile button
  • Select option Reset to factory settings
  • Activate [x] Reset entire user profile
  • Click button Apply Changes and Restart

If the answer is correct or helped you to solve your problem, please click the check mark (:heavy_check_mark:) next to the answer.

The user profile is something we never think about. Thanks a lot it solved the latency that i got when starting LO

In my case LibreOffice startup required about 20 seconds. Solution with safe mode didn’t help.

Correct solution was to clear recent documents list: File -> Recent Documents -> Clear list. I managed to reduce startup delay to 4-5 seconds.
I suppose that LibreOffice checked something about these files on startup and, since many of them are on remote drive in my case, it takes to long.

Your statements do not match - “Solution with safe mode didn’t help” is not compatible with your solution, since in Safe Mode there is no recent documents list and if your solution is removing the cause of the delay then Safe mode must have it removed all the more, because Safe Mode starts with a temporary user profile having no Recent Documents list at all.

I wonder if Windows explorer recent files is the issue in the above case. If there is a very large recent file, e.g. 1GB movie file then Windows explorer can take a very long time to react to anything, even a call to navigate to a different file.

@anon73440385, I believe you are right, but I also quite sure that there was big delay in Safe mode. I tried to reproduce this behaviour on my two other PCs, but they do not have this huge delay between opening file with LibreOffice and showing the file editing interface.
Nevertheless, I am positive that I solved my delay issue after clearing recent documents list. It may be a lightweight solution for some cases, that why it still worth publishing here IMHO.