Writer : how to insert colored typing

I want to insert red comments in a text file. If I choose red font color I can type one comment, then, if I move to a different place and start typing again, it reverts to black. Please, how can I make it stay red?

I tried to understand you question, but in Writer when comment is inserted, no font color change is possible (LibreOffice versio 4.0.4). So, can you explain your question a bit more?

Thank you Ljiljan. I think you have answered it – it cannot be done: although it seems a natural thing to want to do. I now do it by typing my comment, selecting it, and clicking “font color” which is set to red.

Here’s another suggestion, based on the “problem” itself. The text you insert will always take its settings from context. That’s why, of course, when you re-position your cursor to insert a new comment it is black “again”, instead of red.

You could make that work for you. Do you enclose your comments in, e.g., square brackets? If you’re going along making quite a few comments, then:

  • Make an “empty” set, just open/close: []
  • then select this pair of characters, and apply “red”, just as you are doing at the moment;
  • while still selected, hit CTRL-C to “copy” your brackets;
  • now when you go to your next insertion point, hit CTRL-V to paste > left-arrow once, to put the cursor in the brackets, and start typing.

Your red-brackets will be available until your next copy/paste operation. Might make for a smoother “work flow”? At least it’s an alternative approach. Might be an improvement … or not. :slight_smile:

not bad idea :slight_smile: it is good approach if you decide to write comments at once…

@dajare , this is exactly what i do. Same reason. and if the work is extensive, i even make it a little macro so that i keep putting the “comment flag” and at the end, i do Find&replace for the comment brackets to delete them and leave only my notes. as a writer, i do this for updates and rewrites… new color shows new text…

There is also the possibility to uses “record changes” . This way the color is customizable and stays the same until “record changes” is stopped.

@dajare’s idea is very smart one - Thanks I keep this in mind.

General comment: The word “comment” is very dangerous because it can have many meanings. Does comment mean a general comment placed in the text with [] brackets or is it a comment created by
Ctrl+Alt+C or with this image description little icon?

Unfortunately, so far it is not possible to change the font settings for comments.

This answer to a related question links bug fdo#33130 (a request for enhancement) as well as https://issues.apache.org/ooo/show_bug.cgi?id=109773.

Perhaps you would like to weigh in, since the enhancement bug does not specifically include font color change.

Credit: manj_k