writer (soffice.bin) eats all the cpu after a while until save

After some time (15 minutes? 30 minutes? 45 minutes?) soffice.bin process starts to eat 100 % of cpu time (as seen with top utility). It stops after I save a document that is open. Autosave does not stop it, only the save command from the user.

Documents I use are text only, typically few dozen pages. I don’t know if the problem appears with shorter documents. I use odt file format and default settings.

LibreOffice version:
Kernel 4.19.118
hardware: Raspberry Pi 4, 4 GB
OS: Raspbian (Raspberry Pi OS), 32-bit, based on Debian buster

Exactly the same problem appeared on IBM T43 computer with Slackware 14 (OS) and a bit older LibreOffice version

Hello, does the same problem appear, when LO is run in Safe Mode?

Tried it and it happens also in Safe Mode.


  • Could you provide a document with which the behaviour can be reproduced. (add to question via edit)


  • Does user input have to happen or is the behavor independent from it, as far as you can tell/see?
  • Is there any other user started process running beside the desktop env.?

The problem happens even without any user input (beyond opening a new text document from the startup menu). I just tried it without typing a single character and it took 50 minutes before the issue appeared. I typically have Emacs and Firefox and terminal-emulators (using ssh) open at the same time.

First of thanks for the precise description

Now , just to get our testsetup the synced, did i understand correctly that for your latest test, you opened an empty document and waited (50 Minutes), while monitoring the cpu load?

Yes, you got it right.

The suspicious thing with this issue is that both setups I mentioned in the beginning (RPi4 with its official OS and IBM T43 with Slackware) are really slow compared to modern desktop computers (RPi4 roughly corresponds to year 2007 desktop computer, T43 is yet much slower). I’m pretty certain that the issue didn’t occur with Lenovo Thinkcentre M55 (4 GB, Debian) which is what used to be a powerful desktop computer when it was released in 2006 (not sure how M55 compares to RPi4. All these systems have had 32-bit OS, though RPi4 and M55 have a 64-bit capable processor).

i was able to reprduce your findings.
And i could also confirm, that saving the document seemed let the cpuload go down again.
Very strange. I’ll experiment a bit more with this.

I this behaviour could be classified as a bug and reported here:


After saving the docment once i have now left the vm running and in the hours i seems the cpu load has not spiked again.

I’ll now try to open another document ans see if it really only happend when you open a document initally and do not save it.

My experience has been that the problem is persistent in a way that when I save a file (which usually has not been initially empty) by pressing ctrl+S, the cpu-spiking appears again after some time has passed.

well that seems a bit differnt from what i could observe. i will monitor it a bit longer and see if i can see similar pattern or not.

[update 1]

So i left the vm running through the night and the spike did not reaccure with a newly opened image,
i will now try to restart LO and see if it happens again.

[update 2]

After restarting LO … now the load is up again.
So in my case it seems to be related to the first start and not saving the document for a certain period of time.

The other things you mentioned i can not confirm, sorry. But in my experience it would be good not to jump to conclusions. Just report you/our findings as a bug in the most details possible ans see what the devs think about it. The easier it is to reproduce, the better they can debug and maybe fix it.

I just filed an official bug report

Hi, my LO does the same thing. I am using Bunsenlabs on an old HP Elitebook 2540p. I don’t notice any loss of performance, but if I have LO open but not in use for any length of time, I sometimes hear the laptop fan start going like the clappers. When I check, using top, soffice.bin is using 100% of the CPU. It even does this when LO is open but with no file open. Sorry, but I’m new to this community - should I report this somehow, or has it been done? Thank you :slight_smile:

On my Dell latitude 5590 (and although with an other little older dell latitude) with 8Go RAM, SSD disk, with LO, it is the same issue, when launch writer, a few time after, often, fans are starting. Even if writer is stopped, htop show one soffice.bin process running on one (the fourth) on eight cores which are loaded at 100%