Sorunuzu Sorun

LeMoyne isimli kullanıcının profili - etkinlik

2020-08-08 12:26:02 +0100 rozet alındı  Güzel Cevap (kaynak)
2018-11-17 06:55:10 +0100 rozet alındı  Öğretmen (kaynak)
2015-02-15 22:10:49 +0100 bir soru cevapladı ./autogen.sh: configure: error: Python headers not found. You probably want to set both the PYTHON_CFLAGS and PYTHON_LIBS environment variables.

first problem looks like: checking Python.h usability... no -- It's a long shot-> maybe check the file permissions in the include dir?

More directly you could try (from $>./autogen.sh --help)

--enable-python= ONE OF: no/auto/system/internal/fully-internal

                      Enables or disables Python support at run-time and
                      build-time. Also specifies what Python to use.
                      'auto' is the default. 'fully-internal' even forces
                      the internal version for uses of Python during the
                      build.

I would try autogen with --enable-python=internal

And if that fails try =fully-internal

As you figure out the flags that you need, add them to <your-path>/core/autogen.input file.

I suggest you ask your future build questions on the dev list -- http://lists.freedesktop.org/mailman/...

All that said, unless you have been setting this option to 'system', the 'auto' default should have fallen back to internal. Poking around in /core, I have seen what appears to be an internal Python 3.3... Looks like you are encountering an issue with the configure script, but I think =internal will help get you further along.