Frage stellen
0

Fehlermeldung "bad allocation"

gefragt 2017-09-25 11:46:52 +0100

Public Image Gravatar-Bild

WIN 10 (64) - LO 5.4.1.2 Plötzlich scheitert der Versuch ein Writer-Dokument zu öffnen mit der Fehlermeldung "bad allocation". Das Textdatei enthält keine Bilder und keine Verknüpfungen und ist ganze 7 Seiten lang. Der Versuch die Datei von der Backup-Platte zu starten, führt zur selben Fehlermeldung. OO 4.1.2 auf einem anderen Rechner öffnet die Datei problemlos. Weiß jemand Rat?

Wenn zu der fehlenden Unterstützung von PS-Fonts jetzt auch noch Bugs hinzukommen, die einen produktiven Einsatz von LO erschweren, überlege ich wieder auf OO zu wechseln.

edit retag flag offensive close merge delete
0

geantwortet 2017-09-27 09:55:22 +0100

Public Image Gravatar-Bild

updated 2017-10-07 11:38:24 +0100

Das klingt nach einer richtig gute Idee mit der doppelten Konvertierung über OO. Allein: - die Datei in OO als "doc" abgespeichert und versucht sie in LO zu öffnen > bad allocation - die Datei in OO als "odt" abgespeichert und versucht sie in LO zu öffnen > bad allocation

Es deutet hier also einiges nicht nur auf eine korrupte Datei, denn OO kann problemlos damit umgehen, sondern auf einen Bug in LO.Ärgerlich, denn eigentlich möchte ich nicht zurück zu Apache. Aber ich denke, ich werde OO und LO erst mal parallel installieren. Auch, um wieder Type 1 Fonts einsetzen zu können. Schließlich sind 90% meiner Datein mit diesen Fonts generiert worden. Und alle unsere (Laser-)Drucker haben PS-Interpreter.

Ergänzung: Der Fehler ("bad allocation") tritt jetzt bei allen Dateien auf, die Type 1 Fonts enthalten. Und da meine "Brot & Butter Schriften" alle PS-Fonts sind, kann ich im aktuellen LO die meisten meiner Dokumente nicht mehr öffnen. Die Konsequent ist eine Paralell-Installation von OO. Wenn zukünftige Versionen von LO nicht wieder Type 1 Fonts unterstützen, werde ich zwangsläufig wieder zum Vollblut-Apachen.

edit flag offensive delete link mehr
0

geantwortet 2017-09-26 08:51:20 +0100

Toxitom Gravatar-Bild

Echten Rat? Nein. Der Fehler deutet auf einen Fehler im XML code der Datei hin - Irgendein Tag ist falsch gesetzt oder wird nicht mehr unterstützt. Warum und wo ?? Dazu müsste man die Datei analysieren - und der Aufwand lohnt in der Regel nicht.

Wenn Du keine Probleme hast, die Datei mit AOO zu öffnen, kannst Du den folgenden Versuch wagen: Öffnen der Datei in AOO, Speichern unter *.doc (also das "alte" Wordformat). Und diese Datei dann mit LibreOffice öffnen und wieder als *.odt abspeichern. Über diese Weg wird die Datei zweimal konvertiert - die Tags neu geschrieben. Da der Doc-Filter relativ gut ist in beiden Programmen und Du keine Besonderheiten in der Datei hast, wäre dies ein Versuch.

Ansonsten: Wenn Du mit AOO zurecht kommst und mit den Möglichkeiten zufrieden bist... dann bleib doch dabei. Freie Welt, freie Programme. Jeder wie er mag:)

Viele Grüße

Tom

edit flag offensive delete link mehr
Registrieren oder einloggen, um zu antworten

Antwortwerkzeuge

1 follower

Stats

Asked: 2017-09-25 11:46:52 +0100

Seen: 158 times

Last updated: Oct 07