LO 6 verkleinert Textfelder unerwünscht [Geschlossen]

gefragt 2018-05-03 21:10:14 +0200

Penni Gravatar-Bild

updated 2018-05-04 12:25:00 +0200

Hallo, ich hab mir mit LO 5 eine Schablone für meine Adress-Aufkleber erstellt. Nun wollte ich diese mit LO 6 weiter benutzen. Allerdings verändert LO 6 die Textfelder der Schablone und macht sie damit unbrauchbar.

Es handelt sich um die selbe (nicht die gleiche) Datei. Alle Angaben zu den Textfeldern, wie Position und Grösse sind unverändert. Nur passt die Grösse der Textfelder nicht zu den gespeicherten Werten. Veränderte Werte für Feld-Ränder oder ähnliches habe ich nicht gefunden. Anbei Ausschnitte der Screenshots zu Thema. Bildbeschreibung

Was kann man da tun?

MfG, Penni d:-)

Ich versuche mal , ob ich hier die Datei hochgeladen bekomme.

C:\fakepath\Adressetikett_a.odt

Bearbeiten Tags ändern Melden wieder öffnen vereinen löschen

Geschlossen aus folgendem Grund Die Frage ist nicht bedeutend oder inzwischen veraltet von ebot
Abschlussdatum 2018-09-05 07:50:18.917994

Kommentare

Hi Penni, kannst Du die Datei irgenwo hochladen und den Link hier bekanntgeben?

ebot Gravatar-Bildebot ( 2018-05-04 06:09:28 +0200 )Bearbeiten

Klar, könnte ich. Aber ich hatte bisher kein Bedarf an "Hochladen". Welchen Dienst benutzt man denn da am besten?

Penni Gravatar-BildPenni ( 2018-05-04 11:54:57 +0200 )Bearbeiten

Na da brauch ich ja garkeinen externen Dienst. Die Datei ist hochgeladen.

Penni Gravatar-BildPenni ( 2018-05-04 12:26:05 +0200 )Bearbeiten

Also, ich habe Deine Datei geöffnet. Für die Größe der Felder sehe ich die Werte, Breite: 8,51 cm und Höhe: 0,61 cm. Die Schriftgröße ist mit "DejaVu Sans Mono", 16pt, angegeben. Das kann nicht zusammenpassen. Ist es denkbar, dass jetzt eine andere Schrift verwendet wird, da hat sich nämlich (bei den Schriftarten) einiges geändert. Es werden nicht mehr alle Schriftarten unterstützt. Aber das kann nicht alleinige Ursache sein. Hattest Du die Maße auch schon bei LO 5.1.6.2 ? Bei mir LO 6.0.3.2

ebot Gravatar-Bildebot ( 2018-05-04 15:33:51 +0200 )Bearbeiten

Die Werte sind bei mir in beiden LO Versionen 8,50 und 0,60. Die geringe Abweichung kann evtl. mit unterschiedlicher Bildschirmauflösung erklärt werden? Das kann es nicht sein. Die auftretende Abweichung ist wesentlich grösser. Die Schriftart und Grösse wird mir in beiden LOs identisch angezeigt. Dass Schrift und Feldgrösse nicht zusammenpassen hat eine andere Ursache. So war es für mich am einfachsten, die Buchstaben exakt in den vorgedruckten Zeilen des Klebeetikettes zu positionieren.

Penni Gravatar-BildPenni ( 2018-05-04 16:27:40 +0200 )Bearbeiten

Sorry, gerade fällt mir ein, dass ich dieses Problem wohl auch schon hatte. Ich hatte meine Text-Felder damals über die Symbolleiste Formular-Steuerelemente neu kreiert. Bei Deiner Datei würde ich aber die Textfelder durch Rahmen ersetzen. Ist die Datei ein Vordruck für ein offizielles Post/DHL-Formular? Welches? Ich würde es gerne testen. Trägst Du die Daten jedes mal ein oder sind die Felder mit einer Datenbank verknüpft?

ebot Gravatar-Bildebot ( 2018-05-04 19:52:19 +0200 )Bearbeiten

Ich dachte ich hatte was übersehen und man kann es besser machen. Wenn der Fehler nicht behebbar ist, ändere ich mir die Schablonen. Das dauert soo lange auch nicht. Und ich brauch es nicht täglich. Die Daten kopiere ich aus den Info-Mails meiner Tauschbörse. Es sind allgemeine Adressetiketten, die man sicher nur hier in der Schweiz bekommt. Danke für Dein Interesse.

Penni Gravatar-BildPenni ( 2018-05-04 23:55:37 +0200 )Bearbeiten

Nein, übersehen hast Du wohl nichts. Versuche die Felder doch mal als Rahmen anzulegen wenn Du es überarbeitest. Mit Doppelklick auf einen Rahmen kannst Du in der Dialogbox "Position" und "Größe" schützen. Mir viel noch auf, dass das linke Absenderfeld(?) etwas über den unteren Rand ragt, vermutlich durch das drehen des Feldes. Ich habe jetzt auch nicht nachgeschaut, ob es sich bei dem Problem um einen Bug handelt. Wenn Du Zeit und Lust hast: https://bugs.documentfoundation.org/

ebot Gravatar-Bildebot ( 2018-05-05 15:33:41 +0200 )Bearbeiten

Hab ich gemacht, die Felder als Rahmen. Für Grösse und Position die Werte der alten Felder benutzt, Ränder und Innenabstände auf null gesetzt. Funktioniert einwandfrei. Das Abserderfeld ragt über den Rand? Als ich es abschickte tat es das noch nicht. Dieses Feld wurde noch mit Softmaker Office erstellt. Ich werde es hüten wie etwas unersetzliches. Es ist das einzige Feld, das ich kenne, wo der Text mehrzeilig um 270 Grad gedreht erscheint. Fortsetzung folgt...

Penni Gravatar-BildPenni ( 2018-05-05 19:36:49 +0200 )Bearbeiten

Fortsetzung: Das ist mir in LO weder mit einem Feld noch mit einem Rahmen gelungen. Die Drehung bekomme ich hin. Aber die Zeilen sind danach alle in einer Zeile hintereinander, die unterste zuerst. Da bleibt nur, für jede Zeile einen separaten Rahmen einzurichten. Aber das wird nun zu sehr OT. Für die Bugreports ist mein Englisch nicht gut genug. Naja, wenn mal was wichtiges fehlen sollte, hole ich mir einfach wieder Softmaker. Schönes WE!

Penni Gravatar-BildPenni ( 2018-05-05 19:56:16 +0200 )Bearbeiten