Frage stellen
0

Fehler in Base - Datenbanktabelle kann nicht geöffnet werden :(

gefragt 2018-10-10 13:54:48 +0200

Dieser Post ist als Wiki-Post markiert

Das ist ein Wiki-Beitrag. Jeder mit Karma >75 darf diesen Beitrag verbessern.

Hallo, nachdem vor etwa einer halben Stunde LO bei mir abgestürtzt ist und ich danach das Programm bzw. die Datenbank wieder öffnen wollte, zeigte sich immer die Fehlermeldung Bildbeschreibung

Wenn ich auf mehr klicke, erscheinen folgende weitere Fehler:

  • Die Verbindung zur Datenquelle "mögliche Kunden" konnte nicht hergestellt werden.
  • Fehler-Code: 1000 Die Treiberklasse '' konnte nicht geladen werden.
  • SQL-Status: HY000 Die Treiberklasse '' konnte nicht geladen werden.

Weiß von euch jemand, was man da machen kann? Bin echt verzweifelt, weil da eine Menge an Arbeit drinnen steckt... :(

Bin über jede Art von Hilfe dankbar!

Beste Grüße,

Friedrich Schneider

Bearbeiten Tags ändern Melden schließen vereinen löschen

Kommentare

Ich kann mich dem ersten Beantworter nur anschließen: private Daten gehören hier nicht her!

Bei base Datenbanken handelt es sich standardmäßig um sog. HSQL Datenbanken. Diese können unter Umständen (d.h. von mir nicht getestet) aus dem backup hergestellt werden, indem die Werkzeuge des Herstellers genutzt werden.

Fragensteller Gravatar-BildFragensteller ( 2018-10-12 22:14:00 +0200 )Bearbeiten

Die Datei "backup" scheint ebenfalls nicht korrekt lesbar zu sein. Ich habe über die Einstellung "modified=yes" in der database/properties-Datei versucht, die backup-Datei wiederherzustellen. Hat nicht funktioniert. Vermutlich ist die script-Datei nicht mehr stimmig.

RobertG Gravatar-BildRobertG ( 2018-10-13 18:13:34 +0200 )Bearbeiten

1 Antwort

0

geantwortet 2018-10-12 20:41:15 +0200

RobertG Gravatar-Bild

Die hinter dem Link steckende Datenbank ist defekt. Es werden nur einige darin enthaltene Dateien (*.odb ist ein gepacktes Verzeichnis) beim Entpacken erkannt. Ein kurzer Versuch, die Daten durch einen Transport der eigentlichen Datenbankdateien in eine neue Datenbankdatei zu transportieren schafft es Base nicht, das Ganze als Datenbankdatei zu öffnen. Wo da genau der Fehler liegt und warum das System zwei der Dateien aus dem "database"-Ordner den Zusatz ".new" verpasst hat kann ich so nicht klären. Auch ein Versuch, die Daten aus der Backup-Datei zu lesen, schlägt erst einmal fehl.

Allerdings sind in der Datei einige Datenzeilen enthalten, die weiter lesbar sind. Allein aus dem Grunde würde ich empfehlen den Link so schnell wie möglich wieder zu entfernen.

Bearbeiten Melden löschen Link mehr
Registrieren oder einloggen, um zu antworten

Antwortwerkzeuge

1 Beobachter

Statistik

Gefragt: 2018-10-10 13:54:48 +0200

Angesehen: 159 Mal

Aktualisiert: Oct 13 '18