Frage stellen
0

Installierte OpenType Schriften unter LibreOffice 6.3.3 (Ubuntu) nicht verfügbar

gefragt 2019-11-22 17:52:20 +0100

CKn Gravatar-Bild

Nach Installation der Schriftfamilie Latin Modern (Paket lmodern) in Ubuntu 18.04 werden die Schriften im GNOME Font Viewer ("Schriften") angezeigt. Die entsprechenden otf-Dateien (OpenType) sind am Rechner tatsächlich vorhanden. Trotzdem können sie in LibreOffice 6.3.3 nicht verwendet werden (Schriftname kursiv, Tooltip: "Die gewählte Schriftart ist nicht verfügbar und wird ersetzt.").

Trotz mehrmaligem Rechnerneustart und "sudo fc-cache -f -v" erkennt LibreOffice diese in Ubuntu verfügbaren OpenType-Fonts nicht. Aktuell bin ich ratlos. Unter Ubuntu 16.04 + LibreOffice 5.1.6 gibt es dieses Problem nicht.

Ich dachte, dass nur die Unterstützung von Type 1 Schriften in neueren LibreOffice-Versionen gestrichen wurde (ab LibreOffice 5.3) ...

Bearbeiten Tags ändern Melden schließen vereinen löschen

Kommentare

Es gibt auch Bugs ;-) - aber kann es sein, dass Du diese Meldung nur bei existierenden Dokumenten und bei neuen Dokumenten auf der Basis alter Templates bekommst? Ich würde LibreOffice mal mit einem temporären Profil starten - etwa so /usr/lib/libreoffice -env:UserInstallation=file:///tmp/LO-Temp-Profile und dann ein neues Writer File öffnen und testen, on die Fonts dann sichtbar sind. Auf meinem Ubuntu 18.04 Testsystem jedenfalls gibt es nach Installation von apt install lmodern kein Problem mit den Fonts.

PS: Mit den Type 1 Fonts hast Du recht und OTFs sollten gehen, wenn nicht, würde ich darin einen Bug sehen. Im Moment sehe ich aber noch eher ein Problem auf Deinem System.

Opaque Gravatar-BildOpaque ( 2019-11-22 19:07:49 +0100 )Bearbeiten

Vielen Dank für den Tipp. Bei mir hat das nichts geändert.

CKn Gravatar-BildCKn ( 2019-11-23 22:46:56 +0100 )Bearbeiten

1 Antwort

0

geantwortet 2019-11-23 22:49:47 +0100

CKn Gravatar-Bild

updated 2019-11-23 22:50:42 +0100

Nachdem auch eine Neuinstallation von LibreOffice nichts gebracht hat, habe ich die OpenType-Fonts händisch in das Verzeichnis /usr/share/fonts/opentype/lm kopiert. Danach wurden sie auch von LibreOffice erkannt ("sudo fc-cache -f -v" nicht vergessen ;-)

Bearbeiten Melden löschen Link mehr

Kommentare

Das klingt aber nach einem Problem mit der Installationroutine nach einem apt install lmodern - Das die LibreOffice-Neuinstallation nichts gebracht hat, wundert mich absolut nicht, denn LibreOffice nutzt lediglich die vom Betriebssystem zur Verfügung gestellten Fonts. Anyway ... jetzt scheint es ja zu gehen,

Opaque Gravatar-BildOpaque ( 2019-11-24 12:23:34 +0100 )Bearbeiten
Registrieren oder einloggen, um zu antworten

Antwortwerkzeuge

1 Beobachter

Statistik

Gefragt: 2019-11-22 17:52:20 +0100

Angesehen: 35 Mal

Aktualisiert: Nov 23