Frage stellen
0

Probleme mit Datum in calc

gefragt 2020-02-08 12:00:20 +0100

wodan51 Gravatar-Bild

Hallo Ich habe einige Probleme mit dem Datum in calc. Wenn ich ein xls-File erhalte von einer Bank beispielsweise, so ist das Datum im Format tt/mm/jjjj. Ich selektiere nun die Kolonne und gehe zu Format/Zellen und selektiere Datum-->31.12.1999. Aber nichts geschieht. Von einer anderen Stelle erhalte ich zwar das Datum im (formal) richtigen Format, aber es scheint als Text wahrgenommen zu werden. Denn, wenn ich wie oben beschrieben die Kolonne als Datum markiere, erhalten alle Einträge ein '. Also vom 20.01.2020 wird '20.01.2020 und ist bei der Sortierung total falsch.

Ich weiss nicht mehr weiter.

Danke für eure Hilfe.

Bearbeiten Tags ändern Melden schließen vereinen löschen

Kommentare

Bitte Betriebssystem und Version von Libre Office nachtragen. Und mit angehängter Beispieldatei könnte man dies ggf. auch nachvollziehen. Ich wüsste nicht wo ich jemals mit dem Datum Probleme gehabt hätte

jokrebel Gravatar-Bildjokrebel ( 2020-02-08 12:18:55 +0100 )Bearbeiten

Win10 x64 Pro Build 1909, LibreOffice 6.4.0.3

wodan51 Gravatar-Bildwodan51 ( 2020-02-09 17:20:16 +0100 )Bearbeiten

2 Antworten

1

geantwortet 2020-02-08 14:16:12 +0100

Opaque Gravatar-Bild

updated 2020-02-10 10:23:20 +0100

Hallo,

Fall 1: Format tt/mm/jjjj

Hier ist es meiner meiner Meinung nach am einfachsten in einer deutschen Sprachumgebung, den Schrägstrich / über Bearbeiten -> Suchen & Esrsetzen in einen Punkt . zu verwandeln:

  • Spalte markieren
  • Bearbeiten -> Suchen & Esrsetzen
  • Suchen: /
  • Ersetzen: .
  • Weitere Optionen: [x] Nur in Auswahl
  • Button: Alle ersetzen klicken

Die Umwandlung in ein Datum sollte automatisch erfolgen (Wenn eine Bank ein Datumsformat so ausliefert, kann ich eigentlich nur den Kopf schütteln, und wenn es eine deutsche Bank sein sollte, wäre ich ein wenig sprachlos)- Formatieren hilft hier erst mal gar nichts, da das angebliche Datum weder als Datum noch als mögliches(!) Datum erkannt und mit einen Anführungszeichen versehen wird (siehe auch Fall 2:).

Fall 2: Formatierung erzeugt einfaches Anführungszeichen

wenn das Datum nach einer Spaltenformatierung ein einfaches Anführungszeichen erhält bedeutet das zweierlei:

  • Es ist - wie Du schon vermutet hast - Text und kein richtiges Datum
  • LibreOffice Calc hat erkannt, dass es ein Datum sein könnte(!) (und hiermit wird die Konvertierung dann auch sehr einfach)

Konvertierung

  • Spalte markieren
  • Daten -> Text in Spalten
  • Darauf achten, dass der Spaltentyp Standard ist
  • OK klicken

Danach sollte sich der Text in ein Datum verwandeln und damit die Werte sich auch rechts an der Zelle ausrichten (Nebenbei: An der Ausrichtung links an der Zelle kann man im Normalfall auch immer leicht erkennen, dass es in Wirklichkeit kein Datum ist, da ein Datum eine Zahl ist und diese rechts ausgerichtet sind).

[Update - siehe Kommentar von OP]

Bildbeschreibung

Bildbeschreibung

Zur Sortierung: Die ist natürlich nur im Sinn Deiner Erwartung "Datumssortierung" falsch. Da die Werte aber Text sind und keine Zahlen, wird Text sortiert und damit ist die Sortierung technisch betrachtet schon korrekt, entspricht nur nicht Deiner Erwartung. Sobald die Konvertierung geklappt hat, sortiert sich das auch so, wie Du es erwartest.

PS: Dieses Verhalten ist bei Importen aus dem .xlsx häufig zu beobachten und in Deinem Fall liegt es mit Sicherheit daran, dass in Deutschland und in einer DE lokalisierten LibreOffice Installation das Format "tt/mm/jjjj" einfach nicht den landesspezifischen Gewohnheiten entspricht. In Deutschland schreiben wir ein Datum einfach nicht so, und daher wandelt LibreOffice das auch nicht um - Das einzige weltweit unmissverständliche Format ist nun mal das ISO Format yyyy-mm-dd

Ich hoffe, dies hilft Dein Problem zu lösen / Deine Frage zu beantworten

Wenn die Antwort geholfen hat, Dein Problem zu lösen, dann klick bitte das kleine Häkchen (✔) direkt neben der Antwort (wird grün dabei).

Bearbeiten Melden löschen Link mehr

Kommentare

Besten Dank, Variante 1 hat sehr geholfen. Bei Variante 2 finde ich "Daten -> Text in Spalten" nicht. Und ich weiss auch nicht, wo ich den Spaltentyp finden könnte. NB: Bank ist im Tessin/CH. Ich weiss auch nicht, wieso sie das Englische Format verwenden, ich habe SG bei mir.

wodan51 Gravatar-Bildwodan51 ( 2020-02-09 17:16:28 +0100 )Bearbeiten

Daten - Text in Spalten ist nur dann nicht ausgegraut, wenn Du ein Spalte / einen Spaltenbereich selektiert hast - siehe den Screenshot in meinem Update der Antwort. Der Spaltentyp befindet sich dann in dem zugehörigen Dialog (wenn Du den aber schon nicht gefunden hast, findest Du den Spaltentyp natürlich erst recht nicht)

Opaque Gravatar-BildOpaque ( 2020-02-10 09:37:13 +0100 )Bearbeiten

Danke Ich habe die Spalte (A1:A1048576) zwar selektiert, dann aber die erste Zeile wieder ausgeladen, da diese keine relevanten Daten enthält und nur eigentlich Titeldaten beinhaltet (A2:A1048576). Und schon ist "Text in Spalten" ausgegraut und deshalb kaum sichtbar.

wodan51 Gravatar-Bildwodan51 ( 2020-02-12 00:43:48 +0100 )Bearbeiten
0

geantwortet 2020-02-08 17:56:15 +0100

Lupp Gravatar-Bild

updated 2020-02-08 18:01:16 +0100

Wenn die "Datumsangaben" tatsächlich Text sind für beide Fälle:

Spalte (ggf. Bereich der Spalte.) wählen, >Daten>Text in Spalten...>
Bei "Trennoptionen darf unter "Andere" kein Schrägstrich (Slash) oder Punkt eingetragen sein!
Rechtsklick auf Spaltenkopf, Datum(TMJ) wählen, OK.
Fertig.
Die Datumsangaben sind jetzt in die Standardrepresentation als Zahlen für Rechenblätter gebracht. Die enthält auch ihre kleinen Gefahren. Sie ist halt fürs "Rechnen mit Datum" gedacht. Aber nur auf dieser Grundlage ist die Einstellung eines Anzeigeformats unter Zellen formatieren...>Zahlen überhaupt wirksam.

Leider werden sie wohl standardmäßig nun im Format TT.MM.JJ angezeigt. Das ist nicht das "richtige" Format!

Auch DIN 5008 (Brief) legt für die Schreibung von Daten mit Ziffern wie ISO 8601 extended JJJJ-MM-TT als das zu benutzende Format fest. Anscheinend kümmert sich nur immer noch kein Schwein um die Norm. Wie auch international (z.B. für diesen Askbot) werden die absurdesten (teilweise echt dysfunktionalen) Formate erfunden.
Die ISO-Norm ist aber absolut das Beste, was man wählen kann.

https://xkcd.com/1179/

Bearbeiten Melden löschen Link mehr

Kommentare

Leider finde ich ">Daten>Text in Spalten...>" nicht. Daten ja, aber Text in Spalten nicht.

wodan51 Gravatar-Bildwodan51 ( 2020-02-09 17:18:01 +0100 )Bearbeiten

Seltsam. Das gibt's schon lange (immer). Es kann natürlich "ausgegraut" (disabled) sein, falls kein Zellbereich innerhalb der betreffenden Splate ausgewählt ist.

Lupp Gravatar-BildLupp ( 2020-02-09 18:12:23 +0100 )Bearbeiten

Ich habe das von Lupp sofort getestet und war begeistert. Diese Variante kannte ich gar nicht: Inhalt markieren, Daten > Text in Spalten wählen, darin dann Feldbefehle > Standard (Spaltenkopf der Beispieldaten) drücken und den Spaltentyp auf Datum(TMJ) ändern.

RobertG Gravatar-BildRobertG ( 2020-02-09 18:44:15 +0100 )Bearbeiten
Registrieren oder einloggen, um zu antworten

Antwortwerkzeuge

1 Beobachter

Statistik

Gefragt: 2020-02-08 12:00:20 +0100

Angesehen: 52 Mal

Aktualisiert: Feb 10