Ask Your Question
0

Librewriter screen display text gets messed up after scrolling [closed]

asked 2013-01-18 18:55:42 +0200

anonymous user

Anonymous

updated 2015-08-29 15:14:06 +0200

Alex Kemp gravatar image

In librewriter when scrolling up/down the text gets garbled and duplicated fragments of lines everywhere. Screen messed up--like it's not erasing the old text before displaying the current text. Scrolling up/down does not clean up the screen line fragments.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-06 22:07:57.681973

Comments

On which operating system are you experiencing this issue? I know it often occurs on OS X… Please specify your OS with version number, your version of LibreOffice and wether the issue has always been present or started after a change in configuration.

CyanCG gravatar imageCyanCG ( 2013-01-18 19:07:12 +0200 )edit

Libre Officel 3.6.2.2, Ubuntu 12.10 fallback GNOME Classic (no effects), always present.

ubuntu12p10 gravatar imageubuntu12p10 ( 2013-01-23 19:22:11 +0200 )edit

Perhaps the issue is related to Gnome’s “Fallback” mode? I reckon this mode uses older API’s and frameworks…

CyanCG gravatar imageCyanCG ( 2013-01-23 20:00:07 +0200 )edit

Installed OpenOffice. No line fragment issue.

ubuntu12p10 gravatar imageubuntu12p10 ( 2013-01-25 20:56:33 +0200 )edit

Aha! That's interesting, and deserves further investigation.

CyanCG gravatar imageCyanCG ( 2013-01-26 23:52:22 +0200 )edit

@ubuntu12p10 - What version of OpenOffice are you saying is not affected by this?

cipricus gravatar imagecipricus ( 2013-06-10 19:47:35 +0200 )edit

@ubuntu12p10 - Now I see that OpenOffice is version 3.4.1 (while LO is 4.0.1). If these numbers are at least partly correlated, there's no wander OO 3.4 is not affected by the bug: you might as well use LO 3.5

cipricus gravatar imagecipricus ( 2013-06-10 20:03:48 +0200 )edit
1

I've got the same problem with LibreOffice 4.2.6.3, Ubuntu 14.04. Selecting an appropriate JRE Version at Tools->Options->LibreOffice->Advanced helped a lot!

markus69 gravatar imagemarkus69 ( 2014-09-28 16:00:29 +0200 )edit

Then it probably has something to do with LibreOffice’s text display being handled by Java? I knew Java handled user interaction, but I wasn’t sure to what extent it was responsible for display in the document view. I am aware of other applications (such as PyCharm) where changing the JRE can dramatically alter the appearance of text.

CyanCG gravatar imageCyanCG ( 2014-11-10 03:09:53 +0200 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2013-06-10 19:44:09 +0200

cipricus gravatar image

updated 2013-06-10 20:11:23 +0200

I do not have a solution per se, but some advice.

It looks like i have the same problem. This is my question. I think it is the same, look at the images and comment please.

I have filed a bug report here. You may want to add your comments there too. Try to provide info on your operating system, VGA and drivers.

It happened for me first with 3.6 in Ubuntu and then with all the other newer releases. Going back to 3.5 solved it. Updating is not a solution just yet, downgrading to 3.5 is. (That is why OpenOffice is not affected: it is based on a such older version of the program.) To test 3.5 without affecting your normal current installation, try a 'local' install, like indicated here. In the same manner you may test the latest versions to see if the bug is still affecting them.

Also, in my case it happens only above a certain zoom level. Try to use a lower zoom level and see if the problem goes away, and then avoid going above that.

edit flag offensive delete link more
0

answered 2014-12-04 10:19:31 +0200

chrisl gravatar image

same problem after upgrading from ubuntu 12.10 to 14.04 and libreoffice Version: 4.2.3.3

problem was solved by changing JRE setting (as indicated above by markus69, thanks!) from old sun 1.6 to oracle 1.7. seems oracle JRE was updated while updating ubuntu, not sun's

edit flag offensive delete link more
0

answered 2013-04-28 20:07:12 +0200

qubit gravatar image

Hi @ubuntu12p10,

If installing/running the latest release doesn't seem to fix this problem, please file a bug and provide a list of steps that can reproduce your problem. The QA Team will be happy to help you track down this issue!

Please post a link to any bugs you file in a comment below using the format "fdo#123456".

Thanks!

edit flag offensive delete link more

Comments

I have the same problem (see my answer above, including the bug report). there are not too many steps to reconstitute here: it is just that a display problem with certain VGA/video-drivers has appeared in 3.6 version. all previous versions are not affected. the current (june 2013 v.3.4.1) OpenOffice is not affected either.

cipricus gravatar imagecipricus ( 2013-06-10 20:18:11 +0200 )edit

Question Tools

2 followers

Stats

Asked: 2013-01-18 18:55:42 +0200

Seen: 3,290 times

Last updated: Dec 04 '14